java console pops up and mozilla is frozen

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Eric L., Assigned: Joe Chou)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Hi,

when going to http://hpux.cs.utah.edu/, a java console pops up (the java guy
doesn't appear in the task bar) with following message:

Java(TM) Plug-in: Version 1.3.1
Using JRE version 1.3.1 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\elavarde
Exception occurred during event dispatching:
java.lang.UnsatisfiedLinkError: ConsoleStatus
	at sun.plugin.JavaRunTime.ConsoleStatus(Native Method)
	at sun.plugin.JavaRunTime$1.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

I can clear, copy and even close the Java Console but Mozilla is hung
and I can only kill it. IE works like a charm. The same problem appears at
least also on the french mirror of the site.

The primary problem might be a Java problem but then Mozilla should handle this
a bit more nicely ;-)
(Reporter)

Comment 1

17 years ago
I did test the same site at Home (Moz 0.9.8 on Linux) and didn't get any problem.
wfm with win2k and a 2h old CVS build and JRE 1.4

Reporter: 
Can you try it with JRE1.4 ?
A Plugin run's inside the browser and can crash the browser...
Assignee: asa → joe.chou
Severity: major → critical
Component: Browser-General → OJI
Keywords: hang
QA Contact: doronr → pmac

Comment 3

17 years ago
Wfm with JRE 1.3.1_02 on 2002022203, Win98.
(Reporter)

Comment 4

17 years ago
OK, I didn't install Java 1.4 (might do so though) but played a bit with Java
settings and the reason for the crash seems to be that the JIT Compiler was
disabled.
Enable it again and it works now like a charm.

Is this normal? OK, I have a workaround so you can lower the priority, or am I
supposed/allowed to do it myself (process unclear)?

Anyway, thanks for your help.
wfm, applet works, java console doesnt pop up.
using:
moz 1.0 RC1, windows2000, SP2
Java Plug-in 1.4.0 for Netscape Navigator (DLL Helper)
moz 1.0 RC1, Linux, SuSE 8.0 
Java(TM) Plug-in 1.3.1_02



Comment 6

16 years ago
Resolving WFM per comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.