Imported LDAP directory server entries do not show up in Address Book

VERIFIED FIXED in mozilla1.0

Status

defect
--
major
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: iann_bugzilla, Assigned: sspitzer)

Tracking

Trunk
mozilla1.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-ldap)

Attachments

(3 attachments, 1 obsolete attachment)

Using buildID 2002022009 on windows 2000 SP2

When you import a profile from NS4.x which already has directory servers setup
then they appear under prefs addressing in mozilla but don't appear in the
address book and can't be made to appear there without deleting and recreating.

See bug 83114 comments for confirmation
I presume it needs to be assigned to srilatha@netscape.com because it's related
to the other bugs that come under bug 125821
Assignee: racham → srilatha
Blocks: 125821
Severity: normal → major
Keywords: nsbeta1
QA Contact: nbaca → yulian
Whiteboard: nab-ldap
is it in turbo mode (quick launch)?

All the LDAP directories show up in AB after migration if running non-turbo.
Not running in turbo / quick launch mode.

I could post my pre migration NS4.x prefs.js and post migration Mozilla prefs.js
if you want.
Marking NEW. Ian you should contact the correct owner on this list
http://www.mozilla.org/owners.html and get a review/sr for the patch to be
checked in. Thanks for the patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not my patch, so John or module owner needs to progress this.
I forgot about testing migration from 4.x after the bridge code landed.

srilatha is ok with me driving this bug in.  I'll start by looking at the patch.
Assignee: srilatha → sspitzer
Discussed in 2/28/02 Mail & News bug meeting.  Decision was to plus this bug.
Keywords: nsbeta1nsbeta1+
Target Milestone: --- → mozilla1.0
Ian, 

Did You run Mozilla build? With Mozilla Nightly build, LDAP Directory Servers
are migrated to <name>.na2 as John described in Bug 127110. That's why the LDAP
Directory Servers do not appear in Address Book Window. 

With Netscape commercial builds, LDAP Directory Servers plus infospace, verisign
and netcenter get migrated to <name>.mab. Imported LDAP directory servers did
show up in the Address Book window.




Yes I've been running the mozilla nightly build. Presumably the nightly needs to
do the same as the netscape commercial builds
we can't migrate the 4.x .na2 files in mozilla, but we should still be able to 
migrate the 4.x LDAP prefs.
Status: NEW → ASSIGNED
With Mozilla build, there's no problem migrating the 4.x LDAP prefs. 

When you say the LDAP prefs, I presume you mean the entries you find under Mail
& News, Addressing, Directory Server. If so, then yes they do get migrated but
no corresponding entry in the address book appears.
ok, I can reproduce this.

working on it...
john was on the right track back on 2/21.

here comes a similar fix, with some comments added.
Posted patch fixSplinter Review
Attachment #70739 - Attachment is obsolete: true
Comment on attachment 74380 [details] [diff] [review]
fix

sr=bienvenu
Attachment #74380 - Flags: superreview+
Comment on attachment 74380 [details] [diff] [review]
fix

looks good
r=srilatha
Attachment #74380 - Flags: review+
Comment on attachment 74380 [details] [diff] [review]
fix

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74380 - Flags: approval+
fixed.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Verified with Mozilla nightly build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.