Cancel printing of a mail message and you crash

VERIFIED DUPLICATE of bug 126427

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 126427
17 years ago
14 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: rods (gone))

Tracking

({crash, regression})

Trunk
PowerPC
Mac OS X
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
osx build from 2/20/02
select a mail message
click print
cancel the OS print dialog

boom!

 #0   0x03dca3ec in nsBoxFrameInner::Recycle(nsIPresShell *)
 #1   0x03dca3e8 in nsBoxFrameInner::Recycle(nsIPresShell *)
 #2   0x03dc6c08 in nsBoxFrame::Destroy(nsIPresContext *)
 #3   0x03dbde24 in nsFrameList::DestroyFrames(nsIPresContext *)
 #4   0x03be6528 in nsContainerFrame::Destroy(nsIPresContext *)
 #5   0x03d715f8 in ViewportFrame::Destroy(nsIPresContext *)
 #6   0x03e07efc in FrameManager::Destroy(void)
 #7   0x03c179ac in PresShell::Destroy(void)
 #8   0x0312db74 in DocumentViewerImpl::Destroy(void)
 #9   0x036b7a84 in nsDocShell::Destroy(void)
 #10  0x036ec17c in nsWebShell::Destroy(void)
 #11  0x01d5ef48 in nsXULWindow::Destroy(void)
 #12  0x01d45ce0 in nsWebShellWindow::Destroy(void)
 #13  0x01d548e4 in nsChromeTreeOwner::Destroy(void)
 #14  0x0374663c in GlobalWindowImpl::ReallyCloseWindow(void)
 #15  0x03746474 in GlobalWindowImpl::Close(void)
 #16  0x0392e128 in OnStateChange__16nsMsgPrintEngineFP14nsIWebProgressP10nsIReque
 #17  0x031297bc in PrintData::DoOnProgressChange(nsVoidArray &, int, int, int, int)
 #18  0x031295b4 in PrintData::OnEndPrinting(unsigned int)
 #19  0x0312d808 in 0x312d808
 #20  0x036b7a84 in nsDocShell::Destroy(void)
 #21  0x036ec17c in nsWebShell::Destroy(void)
 #22  0x03eafaac in nsHTMLFrameInnerFrame::_dt(void)
 #23  0x03beb814 in nsFrame::Destroy(nsIPresContext *)
 #24  0x03dbde24 in nsFrameList::DestroyFrames(nsIPresContext *)
 #25  0x03be6528 in nsContainerFrame::Destroy(nsIPresContext *)
 #26  0x03dbde24 in nsFrameList::DestroyFrames(nsIPresContext *)
 #27  0x03be6528 in nsContainerFrame::Destroy(nsIPresContext *)
 #28  0x03dc6c20 in nsBoxFrame::Destroy(nsIPresContext *)
 #29  0x03dbde24 in nsFrameList::DestroyFrames(nsIPresContext *)
 #30  0x03be6528 in nsContainerFrame::Destroy(nsIPresContext *)
 #31  0x03dc6c20 in nsBoxFrame::Destroy(nsIPresContext *)
 #32  0x03dbde24 in nsFrameList::DestroyFrames(nsIPresContext *)
 #33  0x03be6528 in nsContainerFrame::Destroy(nsIPresContext *)
 #34  0x03d715f8 in ViewportFrame::Destroy(nsIPresContext *)
 #35  0x03e07efc in FrameManager::Destroy(void)
 #36  0x03c179ac in PresShell::Destroy(void)
 #37  0x0312db74 in DocumentViewerImpl::Destroy(void)
 #38  0x036b7a84 in nsDocShell::Destroy(void)
 #39  0x036ec17c in nsWebShell::Destroy(void)
 #40  0x01d5ef48 in nsXULWindow::Destroy(void)
 #41  0x01d45ce0 in nsWebShellWindow::Destroy(void)
 #42  0x01d548e4 in nsChromeTreeOwner::Destroy(void)
 #43  0x0374663c in GlobalWindowImpl::ReallyCloseWindow(void)
 #44  0x03746474 in GlobalWindowImpl::Close(void)
 #45  0x0392e128 in OnStateChange__16nsMsgPrintEngineFP14nsIWebProgressP10nsIReque
 #46  0x031297bc in PrintData::DoOnProgressChange(nsVoidArray &, int, int, int, int)
 #47  0x031295b4 in PrintData::OnEndPrinting(unsigned int)
 #48  0x03147874 in Print__18DocumentViewerImplFP16nsIPrintSettingsP22nsIWebProgre
 #49  0x0392dd3c in 0x392dd3c
 #50  0x01bb2c10 in FireOnStateChange__15nsDocLoaderImplFP14nsIWebProgressP10nsIRe
 #51  0x01bb0d60 in nsDocLoaderImpl::doStopDocumentLoad(nsIRequest *, unsigned int)
 #52  0x01bb05bc in nsDocLoaderImpl::DocLoaderIsEmpty(void)
 #53  0x01bb005c in nsDocLoaderImpl::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #54  0x0174182c in nsLoadGroup::RemoveRequest(nsIRequest *, nsISupports *,
unsigned int)
 #55  0x04d839b4 in nsImapUrl::RemoveChannel(unsigned int)
 #56  0x04cd9bb8 in RemoveChannelFromUrl__20nsImapIncomingServerFP17nsIMsgMailNews
 #57  0x0030286c in XPTC_InvokeByIndex
 #58  0x00302760 in XPTC_InvokeByIndex
 #59  0x0030d348 in EventHandler(PLEvent *)
 #60  0x00352238 in PL_HandleEvent
 #61  0x00351fd0 in PL_ProcessPendingEvents
 #62  0x002d221c in nsEventQueueImpl::ProcessPendingEvents(void)
 #63  0x034aa0c8 in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #64  0x034a9a98 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #65  0x014b5bb0 in Repeater::DoRepeaters(EventRecord const &)
 #66  0x034c5140 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #67  0x034c4c88 in nsMacMessagePump::DoMessagePump(void)
 #68  0x034c4454 in nsAppShell::Run(void)
 #69  0x01d35ac8 in nsAppShellService::Run(void)
 #70  0x001c5d84 in main1(int, char **, nsISupports *)
 #71  0x001c8424 in main
(Reporter)

Comment 1

17 years ago
i think this needs to be fixed by 099. it's pretty serious.
Keywords: crash, mozilla0.9.9, nsbeta1, regression
(Assignee)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 126427 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.