Extra space below images

VERIFIED DUPLICATE of bug 22274

Status

()

VERIFIED DUPLICATE of bug 22274
17 years ago
17 years ago

People

(Reporter: kehvan, Assigned: attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Images get an extra 3px of space below them. A workaround using "margin-bottom:
-3px;" in CSS works, but must be browser-detected as this rendering error is not
present in IE6 or O6. On the sample URL above, a tiny gap can be seen under the
graphic for "Categories," above the first text link. This can also be seen on
other sites that use fragmented graphics to produce a simulated whole image.

Reproducible: Always
Steps to Reproduce:
1. As mentioned in the description, all graphics get an extra three px of space
below them.
2. Example code: [div][img src="pic"][/div] produces 3px extra space below the
image.


Actual Results:  The above code fragment displays extra space below the image.
This is particularly noticeable on recombined graphics.

Expected Results:  Recombined graphics should appear unbroken, with no extra
space under images.

Actual code that demonstrates the bug:

<div class="categories">
  <div style="margin: 0px 0px 0px 0px;"><img src="images/categories.png"
alt="Categories" width="140" height="30"/></div>
  <div class="category"><a href="category.asp?category=Appliances"
id="Appliances" class="categoryLink">Appliances</a></div>
</div>

A workaround is to detect the GECKO engine and include additional CSS code to
produce a "margin-bottom: -3px;" for images.
This is a problem with the webpage.  We follow the standard.  Read bug 22274 and
http://developer.netscape.com/evangelism/docs/articles/img-table/ for more info.

This looks like your page, reporter, as the page some workarounds already except
in the one position you mentioned.  However it's not the "correct" workaround. 
(Increase your font size to see what I mean).  The bug and the article I posted
have the correct workaround.

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
Changing QA contact
QA Contact: petersen → moied
You need to log in before you can comment on or make changes to this bug.