Closed Bug 1270329 Opened 4 years ago Closed 4 years ago

Use-after-forget in WebMTrackDemuxer::SkipToNextRandomAccessPoint

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1261900
Tracking Status
firefox49 --- affected

People

(Reporter: jld, Assigned: jld)

References

Details

Attachments

(1 file)

It looks like this will be a null pointer crash if logging is enabled:

      mSamples.PushFront(sample.forget());

followed by:

    WEBM_DEBUG("next sample: %f (parsed: %d)",
               media::TimeUnit::FromMicroseconds(sample->mTime).ToSeconds(),
               parsed);

It looks like bug 1190472 regressed this.  Found with the static analysis patches in bug 1186706 (after un-bit-rotting them to test bug 1191452).
Component: Audio/Video → Audio/Video: Playback
I've fixed that one in the pending bug 1261900 (patch 9)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1261900
Attachment #8748973 - Flags: review?(kinetik)
You need to log in before you can comment on or make changes to this bug.