On Linux any downloaded file cannot open with alternate download location

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: miku84, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

I have alternate download location to save files (2nd drive):
///run/media/D
Firefox can save the files but when I click the Firefox downloads button I cannot open the file. Error message: file or location does not exist. I have also tried profile reset as well and delete mymetypes file.
If I change the download location to default everything is working. It is clearly that Firefox cannot reach the target folder and files, however it does not have permission problem.


Actual results:

Files cannot be open. Error message: file or location does not exist. 


Expected results:

Files should be open with alternate download setup, like ///run/media/D.

Updated

2 years ago
Component: Untriaged → Downloads Panel

Comment 1

2 years ago
This bug exists in 46.0.1. Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

Slight clarification: Any path deeper than "/" gets '///' at the start of the path in preferences, when that is passed to KDE Dolphin it resolves as "file or folder does not exist".

Saving files to any given location does actually work but you can't use the 'open containing folder' action in downloads or the toolbar.

Comment 2

2 years ago
If you set the path manually in about:config browser.download.dir eg. /home/xyz/Download it operates correctly. It's definitely those two extra slashes at the start of the path.
(Reporter)

Comment 3

2 years ago
Thanks, it solved the problem :)
Strange is that the link was automatically added with /// when I was browsed the path. This may be an issue.
You need to log in before you can comment on or make changes to this bug.