If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When closing tab, focus should move right

VERIFIED DUPLICATE of bug 105722

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 105722
16 years ago
9 years ago

People

(Reporter: Dominic Battre, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Imagine you have 3 tabs A B C and the focus is on B. Closing the tab with ^W
moves the focus to A instead of C. I think that the latter would be more natural
as it is similar to the behaviour of the delete key in editors.

Example situation: On a newsticker page, you open every news that you are
interested in with the middle mousebutton. You cannot read the news in the order
you opend them if you use ^W to close the tabs. (you have to close a tab and
move the focus to the next one each time)

Comment 1

16 years ago
I agree with the reporter that this is more natural.  Ex: reading a
message thread, you open-in-new-tab the replies in the thread, one
by one.  Then, to read them in the order in which you opened them,
you have to continually forward-peddle to get to the next message
after closing the message you just read.

FWIW, the focus moves right if the leftmost tab is closed.

Comment 2

16 years ago
Al these things are being discussed in bug 105722

*** This bug has been marked as a duplicate of 105722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.