beforeunload not called when tab is closed.

RESOLVED DUPLICATE of bug 796848

Status

()

RESOLVED DUPLICATE of bug 796848
3 years ago
3 years ago

People

(Reporter: amoghbl1, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160502004021

Steps to reproduce:

If you click on the close tab equivalent on firefox for android, i.e:
Tabs > x (next to the tab)
The beforeunload JS code isn't executed.

This is the equivalent of clicking the x on the desktop browser, which causes the code to be triggered. I'm not sure if it's intentionally so or it's a bug.



Expected results:

Is should have called the JS beforeunload code.
Margaret, 
what do you think about this?
Flags: needinfo?(margaret.leibovic)
It is a duplicate of an existing bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(margaret.leibovic)
Resolution: --- → DUPLICATE
Duplicate of bug: 796848
You need to log in before you can comment on or make changes to this bug.