Closed Bug 1270547 Opened 6 years ago Closed 6 years ago

Add SUBPROCESS_SHUTDOWN_KILL to the crash aggregates

Categories

(Cloud Services Graveyard :: Metrics: Pipeline, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: mdoglio)

References

Details

Attachments

(2 files, 1 obsolete file)

60 bytes, text/x-github-pull-request
rvitillo
: review+
Details | Review
55 bytes, text/x-github-pull-request
rvitillo
: review+
Details | Review
In bug 1269961 we added a SUBPROCESS_SHUTDOWN_KILL histogram so that we can measure shutdown-kill crashes separately from others. We need to add this to the aggregates.
Attached file Github PR - aggregate this (obsolete) —
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #8749291 - Flags: review?(rvitillo)
We decided to go with SUBPROCESS_KILL_HARD in bug 1269961 instead, with the reason stored in a keyed histogram. So this patch will need to be updated to handle that. I'm guessing we only want to aggregate on the ShutDownKill reason. Sorry to make this more complicated.
Flags: needinfo?(benjamin)
Attachment #8749291 - Attachment is obsolete: true
Flags: needinfo?(benjamin)
Attachment #8749291 - Flags: review?(rvitillo)
Attached file Github new PR
Attachment #8749697 - Flags: review?(rvitillo)
Attachment #8749697 - Flags: review?(rvitillo) → review+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Reopening this as the code has to be ported to the Scala version as well, which Mauro is planning to deploy asap.
Assignee: benjamin → mdoglio
Duplicate of this bug: 1271333
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file scala implementation
Attachment #8751209 - Flags: review?(rvitillo)
Attachment #8751209 - Flags: review?(rvitillo) → review+
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Product: Cloud Services → Cloud Services Graveyard
You need to log in before you can comment on or make changes to this bug.