firefox android suggests not visited URLs

RESOLVED DUPLICATE of bug 1267208

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1267208
2 years ago
2 years ago

People

(Reporter: pdknsk, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36
Firefox for Android

Steps to reproduce:

I have Search Suggestions disabled, and have Firefox set to clear data on manual exit. So I was quite surprised when I typed p in the address bar and it auto-filled pinterest.com! I have never visited that site, so for a minute I thought I had been hacked. Just to be sure, I fully cleared browsing data manually, and closed Firefox. Still, the same problem. It auto-fills other URLs too. On a, it fills amazon.com, on ame it fills americanexpress.com.

Apparently it could be a feature, as this search reveals.

https://dxr.mozilla.org/mozilla-central/search?q=americanexpress&redirect=false&case=false

If so, it's terrible! Who considered this a good idea? Is Mozilla getting paid for this? Either way, I want  this feature disabled. Please tell me the about:config option to do so. If there isn't any, it should be added pronto.

Updated

2 years ago
Component: Untriaged → General
Product: Firefox → Firefox for Android
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1267208
You need to log in before you can comment on or make changes to this bug.