Multiple dropdown menus on simultaneous Alt+<key> key presses

RESOLVED DUPLICATE of bug 498725

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 498725
2 years ago
a year ago

People

(Reporter: psn, Unassigned)

Tracking

49 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8749315 [details]
doublemenu.png

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160505030327

Steps to reproduce:

While holding Alt key press together G and H; that easily could be done with one finger.
Slightly trickier though still simple are H and V keys or H and E - and probably any other hotkey combination from the main menu.


Actual results:

Two dropdown menus will be displayed as in the attached picture.

Moreover, while writing this after several attempts I made three dropdown menus in Firefox with  F, E and V keys.


Expected results:

There should be no more than one menu.

Comment 1

2 years ago
Was able to reproduce the bug. 
Initially pressed alt+G. The Go menu appeared. Then while holding G, pressed H. No other menu appeared.
Then pressed alt and while holding alt, pressed G and H exactly at the same time. Both the Go menu and the Help menu appeared.
I don't know how this can be solved though. There's already a mechanism in place which prevents any other menu from appearing before all previous drop down menus have been closed. 
I think giving different menus different priorities could be a possible solution so that if two key presses are detected exactly at the same time Thunderbird is able to decide which of the corresponding menus to display.

Comment 2

2 years ago
(how odd that two people should comment on this issue just a few days apart.)

I've often seen this. Mostly from doing Alt+F+E in Firefox.  Not so recently.  Perhaps my newer system is too fast.  

I was not able to find other reports of this in Firefox or Thunderbird - bug query http://mzl.la/24s6kPg
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Untriaged → Mail Window Front End
Ever confirmed: true
Summary: Multiple dropdown menus on simultaneous Alt+keys press → Multiple dropdown menus on simultaneous Alt+<key> key presses

Updated

a year ago
Whiteboard: [dupme]

Comment 3

a year ago
How odd that I've digged out and analysed this problem just a few weeks ago... This certainly looks like a problem in the underlying XUL, as we must never have a situation of double focus. This isn't minor because triggering random commands from menus that should never be open in the first place has a significant potential for errors and dataloss depending on the circumstances.
Severity: minor → normal
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Whiteboard: [dupme]
Duplicate of bug: 498725
(Reporter)

Comment 4

a year ago
> This isn't minor because triggering random commands from menus that should never be open in the first place has a significant potential for errors and dataloss depending on the circumstances.

You could also take into account this report: https://bugzilla.mozilla.org/show_bug.cgi?id=1296240
as another annoying input focus issue.
(Reporter)

Comment 5

a year ago
Slightly different case spotted today, though very much in line with the subject.
I pressed 'Alt+H', then 'a' to get "About ..." dialog.
Instead, I had dropdown for 'Alt+H', but 'a' went to URL input window and list of suggested addresses unfolded under dropdown menu.
You need to log in before you can comment on or make changes to this bug.