Firefox very slow scroll on YouTube.com video page

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: infinium, Unassigned)

Tracking

46 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

Open YouTube.com specific video page. Fresh install of Firefox 46.0.1 (32-bit) on Windows 7 Ultimate (64-bit), bug happens with add-ons enabled or disabled (Safe Mode). Happens with fast internet connection, bug does not exist in Google Chrome (latest version).


Actual results:

Video page loads and when you scroll down it starts loading the comments (ajax). The thumbnails for the 'Up next' videos column that have not been visible until the scroll action show slowly (sometimes very slowly). The comments appear slowly but even after they appear scrolling down is extremely slow - have to drag the scrollbar with the mouse until it finally moves. Sometimes FF freezes for a while when trying to scroll. Now noticed that loading of the thumbs and scrolling on the Youtube homepage is very slow as well.


Expected results:

Youtube video page should scroll normally and comments and 'Up next' video thumbs should load normally. I have used Firefox for a long time and watch Youtube videos regularly, no such bug existed.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
User Agent  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

I am unable to reproduce the issue on the latest Firefox release (46.0.1, Build ID 20160502172042) on Windows 7. I haven't observed any slowness in loading the YouTube video page, comments appear normally and I've experienced no freezes while doing this. Could you please try to reproduce this with a clean new profile?
And if you can reproduce this with a new profile, could you please go to about:memory as you are experiencing the slowness and click "Measure and save..." and post the saved file. 
Also could you please do a profile, using the gecko profiler found here https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Profiling_with_the_Built-in_Profiler, and share the link that the profile generates? It might shed some light on what's causing your Firefox to load slowly.
Flags: needinfo?(infinium)
(Reporter)

Comment 2

2 years ago
(In reply to Ciprian Muresan [:cmuresan] from comment #1)
> User Agent  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101
> Firefox/46.0
> 
> I am unable to reproduce the issue on the latest Firefox release (46.0.1,
> Build ID 20160502172042) on Windows 7. I haven't observed any slowness in
> loading the YouTube video page, comments appear normally and I've
> experienced no freezes while doing this. Could you please try to reproduce
> this with a clean new profile?
> And if you can reproduce this with a new profile, could you please go to
> about:memory as you are experiencing the slowness and click "Measure and
> save..." and post the saved file. 
> Also could you please do a profile, using the gecko profiler found here
> https://developer.mozilla.org/en-US/docs/Mozilla/Performance/
> Profiling_with_the_Built-in_Profiler, and share the link that the profile
> generates? It might shed some light on what's causing your Firefox to load
> slowly.

I seem to have narrowed it down to the Web Developer add-on. So it doesn't seem to be a FF issue after all. Sorry for taking your time. I will leave a comment on the add-on's page so the developer can look into it. Thanks again!
Based on Comment 2 from the reporter, changing status to RESOLVED-WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(infinium)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.