Closed Bug 1270781 Opened 4 years ago Closed 4 years ago

[Gcc 6.1] mozalloc.h:184:44: error: 'bad_alloc' in namespace 'std' does not name a type

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox49 affected)

RESOLVED DUPLICATE of bug 1269171
Tracking Status
firefox49 --- affected

People

(Reporter: fredbezies, Unassigned)

References

Details

Attachments

(1 file)

This bug is more or less related to bug 1269171 or a duplicate ?

It is really simple to reproduce. If you're using Archlinux with testing repositories enabled, you can use gcc 6.1. It is gcc 6.1 output on Archlinux :

$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/6.1.1/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --disable-multilib --disable-werror --enable-checking=release
Thread model: posix
gcc version 6.1.1 20160501 (GCC)

My computer tried to build a new nightly using gcc 6.1 and up-to-date trunk source code.

Every single time, it crash really fast, less than 3 minutes. See attached log.

First error listed is in /include/mozilla/mozalloc.h -> error: 'bad_alloc' in namespace 'std' does not name a type

My glibc version if it helps : 

$ pacman -Qi glibc | grep Version
Version                  : 2.23-2
Forgot to add that patch for bug 1269171 fixes this crash. Sorry if it is a duplicate.
Duplicate of this bug: 1270900
In the end, it's the same as the libc++ one.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269171
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.