Possibly incorrect handling of overflow scenario with elements of width:100%

RESOLVED WORKSFORME

Status

()

Core
Layout
P5
minor
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: vict.shevchenko, Unassigned)

Tracking

({testcase})

45 Branch
All
Windows 8
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Steps to reproduce:

this is a jsFiddle that represents an issue: https://jsfiddle.net/contact/dz3vd51a/

there is an <ul> contains <button style="width:100%"> inlide <li> elements. When this list is in a position where it should overflow parent element only <button> text does this overflow, but <ul> is cropped up to parent border.


Actual results:

<ul> element is cropped up to parent border, <button> text overflows <ul>`s parent 


Expected results:

I`d expect <ul> correctly overflows parent like in Chrome or IE, but quite possible that FireFox does correct rendering. I am not sure, can you clarify if FireFox way of rendering is correct? If yes, sorry a lot for troubling.
(Reporter)

Updated

2 years ago
Severity: normal → minor
OS: Unspecified → Windows 8
Priority: -- → P5
Hardware: Unspecified → All

Comment 1

2 years ago
Created attachment 8749914 [details]
screen-ie.png

I have the same result with IE11 and last FF.

Updated

2 years ago
Component: Untriaged → Layout
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
Hello, Just verified on the latest FireFox (46.0.1) and the behavior is consistent with all other browsers.

So I looks like only v.45 and below had this issue.

I suppose the issue is resolved.
Thanks for your report.  It was probably fixed by bug 823483.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.