Closed Bug 1270888 Opened 4 years ago Closed 4 years ago

we don't have all the spidermonkey jobs in taskcluster

Categories

(Taskcluster :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: sfink)

References

Details

Attachments

(2 files, 1 obsolete file)

in looking at the list of jobs to remove while turning linux64 debug buildbot off, I don't see the taskcluster equivalent of:
-Linux x86-64 fx-team leak test spidermonkey_tier_1-rootanalysis build ScriptFactory
-Linux x86-64 fx-team leak test spidermonkey_tier_1-compacting build ScriptFactory
-Linux x86-64 fx-team leak test spidermonkey_tier_1-arm64-sim build ScriptFactory
-Linux x86-64 mozilla-inbound leak test spidermonkey_info-warnaserrdebug build ScriptFactory

to be honest, I couldn't find these in treeherder at all for buildbot.  I do not know who created the spidermonkey builds or the history, but this needs to be resolved.
Blocks: 1268542
Those are the "ridealong" or "extra" builds added by, I *think*, sfink.
Flags: needinfo?(sphink)
MozReview-Commit-ID: 2rXVMCToDhR
Attachment #8749719 - Flags: review?(jmaher)
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Comment on attachment 8749719 [details] [diff] [review]
Fix the sm-* build types; they are debug but claim to be opt

Review of attachment 8749719 [details] [diff] [review]:
-----------------------------------------------------------------

this looks really good!
Attachment #8749719 - Flags: review?(jmaher) → review+
MozReview-Commit-ID: 2rXVMCToDhR
Attachment #8749721 - Flags: review?(jmaher)
Attachment #8749719 - Attachment is obsolete: true
Not sure why I didn't have this arm64 build in the first place. I'll push it to try to check it out, but it looks straightforward.

MozReview-Commit-ID: 61Ou54OV6Nr
Attachment #8749723 - Flags: review?(jmaher)
Attachment #8749721 - Attachment is obsolete: true
Attachment #8749721 - Flags: review?(jmaher)
Comment on attachment 8749721 [details] [diff] [review]
Fix the sm-* build types; they are debug but claim to be opt

This one is *not* obsolete. Looks like I messed up my local bzexport again.
Attachment #8749721 - Attachment is obsolete: false
Flags: needinfo?(sphink)
Attachment #8749721 - Flags: review?(jmaher)
Attachment #8749723 - Flags: review?(jmaher) → review+
Comment on attachment 8749721 [details] [diff] [review]
Fix the sm-* build types; they are debug but claim to be opt

Review of attachment 8749721 [details] [diff] [review]:
-----------------------------------------------------------------

ok, this looks better!
Attachment #8749721 - Flags: review?(jmaher) → review+
> -Linux x86-64 fx-team leak test spidermonkey_tier_1-rootanalysis build ScriptFactory

It was there on TC, mislabeled as opt.

> -Linux x86-64 fx-team leak test spidermonkey_tier_1-compacting build ScriptFactory

Same.

> -Linux x86-64 fx-team leak test spidermonkey_tier_1-arm64-sim build ScriptFactory

It was not on TC, but is now as of this bug.

> -Linux x86-64 mozilla-inbound leak test spidermonkey_info-warnaserrdebug build ScriptFactory

Replaced with SM(p).

Thanks for noticing these!
https://hg.mozilla.org/mozilla-central/rev/262f13468563
https://hg.mozilla.org/mozilla-central/rev/890ac552f5b4
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Depends on: 1275792
You need to log in before you can comment on or make changes to this bug.