Closed Bug 1271002 Opened 4 years ago Closed 4 years ago

Notify right away after getting the first frame of an animated image

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Explanation in commit message of patch.
Attached patch patchSplinter Review
Attachment #8749885 - Flags: review?(seth)
Blocks: 1233403
Comment on attachment 8749885 [details] [diff] [review]
patch

Review of attachment 8749885 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8749885 - Flags: review?(seth) → review+
The problem is that for anonymous decoders (without an mImage) we don't want to send progress (because there is no where to send that progress).

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b5f815e8ee8e
Flags: needinfo?(tnikkel)
https://hg.mozilla.org/mozilla-central/rev/962463926b90
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.