Seedesks (trading as Seehut Limited)

RESOLVED WONTFIX

Status

Firefox Graveyard
Screen Sharing Whitelist
--
major
RESOLVED WONTFIX
2 years ago
a month ago

People

(Reporter: jon, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
>> Vendor name
Seedesks (trading as Seehut Limited)

>> Point of contact
Jon

>> Site URLs
www.seedesks.com

>> Does the application provide users with notice and control?
http://seedesks.com/terms/

Please see T&C's and also 'Privacy Policy' located at end of T&C's.

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes
(Reporter)

Updated

2 years ago
Severity: normal → major
(Reporter)

Comment 1

2 years ago
Hello,

Trying to get this sorted, your help much appreciated!

Jon
(Reporter)

Comment 2

2 years ago
Sorry one more thing, the site URL's are:

seedesks.com
*.seedesks.com

Comment 3

a year ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Updated

a month ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.