Uncorrect SVG feFuncA behavior

UNCONFIRMED
Unassigned

Status

()

Core
SVG
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: dom1n1k, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8750045 [details]
Left side - buggy result by FF, right side - normal result by Chrome

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Steps to reproduce:

There is gradient, where alpha change from 0 to 1.
Apply filter feComponentTransfer, where
<feFuncA type="linear" slope="10" intercept="0"></feFuncA>



Actual results:

Something happens with RGB-components. Visible posterization. See attached screenshots and test example:
http://codepen.io/dom1n1k/pen/qZgrpr?editors=1100



Expected results:

Slope 10 means to obtain values greater than 1 - they should be clamped (obviously).
Other channels (RGB) should not be touched.

Chrome and IE works fine.

Spec: https://www.w3.org/TR/SVG/filters.html#feComponentTransferElement

Updated

2 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930331
(Reporter)

Comment 2

2 years ago
I'm not sure that this is a duplicate.

Main question not about banding. Main question about influence feFuncA to other channels.
I guess overflow after multiplication alpha channel to large multiplier (slope).

Sorry for my bad english :)
I see banding on the left hand side. I'm not really sure I understand what else you're trying to say here.
Perhaps you could try to create a more obvious testcase?
(Reporter)

Comment 5

2 years ago
Simplified example: http://codepen.io/dom1n1k/pen/ONdjWE

1. In gradient color is constant (orange). Alpha from 0 to 1.
2. Filter should change alpha channel only.
3. But we see changes in other channels (yellow instead orange).

I suspect overflow. Banding - side effect.
Firefox does not support the color-interpolation CSS property. If I remove that Chrome and Firefox look the same. Is that the issue, if so we already have a color-interpolation bug.
(Reporter)

Comment 7

2 years ago
Hmm.
If I delete attributes color-interpolation and color-interpolation-filters, result is slightly different, but still obviously wrong. And not the same with Chrome.
feFuncA should not change color (only alpha). But color was changed.
obviously wrong how?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 9

2 years ago
I attached new picture.
Chrome and IE look slightly different, but within rounding errors.
Firefox - clearly different color.
(testcase - http://codepen.io/dom1n1k/pen/ONdjWE)
(Reporter)

Comment 10

2 years ago
Created attachment 8750096 [details]
See comment #9
You need to log in before you can comment on or make changes to this bug.