Long autocomplete suggestions are clipped in the middle of popup in some cases

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
3 years ago
Last month

People

(Reporter: arni2033, Unassigned)

Tracking

(Blocks 1 bug, {regression})

48 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 unaffected, firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox51 wontfix, firefox52 fix-optional, firefox53 fix-optional, firefox54 fix-optional)

Details

(Whiteboard: [fxsearch], )

Attachments

(1 attachment)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160504043118
Pick any scenario you like. You may need to launch a new profile before testing.

STR_1:
0. Copy URL in the form above to clipboard
1. Open regression range link below in a new window. Resize the window to make it narrow enough
2. Click in urlbar, press Down key to show autocomplete suggestions
3. Click on the free place on the page (as if you were doing something on the page)
4. Open new tab, resize the window to make it wide enough
5. Paste the link copied in Step 1 to urlbar


STR_2:
0. Copy URL in the form above to clipboard
1. Open new window, open new tab in that window, resize the window to make it narrow enough
2. Paste the link copied in Step 1 to urlbar. Press "1" to add it to the string in urlbar.
3. Press Escape twice to hide suggestions and clear location bar
4. Open new tab, resize the window to make it wide enough
5. Paste the link copied in Step 1 to urlbar


AR:  First suggestion is clipped at the same place it was clipped in narrow window.
ER:  Autocomplete suggestions should be clipped near the right side of the panel.

This is regression from bug 1266375. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=6bbcf33e1a709cc6bd9a9ab73e303093fc748239&tochange=597390d44c49cb5c89260feb4f5e1e6ef2eef15c
Blocks: 1262507
Priority: -- → P3
Whiteboard: [fxsearch]
Version: unspecified → 48 Branch
Panos, could you please update the status of 48, 49, 50 as wontfix/fix-wanted/affected, depending on how much we need the fix in any of these releases, so that the triage group knows what the plan is.
Flags: needinfo?(past)
I'm on vacation, so I'll defer to Marco.
Flags: needinfo?(past) → needinfo?(mak77)
Looks like we are missing a window resize event handler somewhere and then rebuild contents on it.

I don't think we should schedule time to fix this shortly, because it requires a very specific sequence (narrow/wide a windows and paste a large text), and also because the remaining space in most cases will suffice (it will look similar to the old autocomplete situation, that sort-of worked for years).

That said, sure, if we could have a patch in time, we could evaluate an uplift.
Flags: needinfo?(mak77)
Priority: P3 → P2
Hi Mak, Panos, is there a fix in the works for this one? We reviewed this is in the platform triage meeting today and wondering if there will be a patch ready for uplift in the early past of beta50 cycle.
Flags: needinfo?(past)
Flags: needinfo?(mak77)
no fix in the works, since this bug is unassigned yet. Is there a specific reason you think this is a critical problem needing an immediate fix, rather than just a fix-optional? We are working on other autocomplete problems that affect a larger number of users atm.
I don't expect the fix to be particularly scary off-hand, if I'm right about the missing window resize handler, so it could also be uplifted a bit later.
Flags: needinfo?(mak77)
What Marco said.
Flags: needinfo?(past)
(In reply to Marco Bonardo [::mak] from comment #5)
> no fix in the works, since this bug is unassigned yet. Is there a specific
> reason you think this is a critical problem needing an immediate fix, rather
> than just a fix-optional? We are working on other autocomplete problems that
> affect a larger number of users atm.
> I don't expect the fix to be particularly scary off-hand, if I'm right about
> the missing window resize handler, so it could also be uplifted a bit later.

I think a fix-optional for 50 is fine. It definitely make sense to fix other higher priority issues before we get to this one.
Priority: P2 → P3

WFM in nightly

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.