[e10s] Sometimes opening a link in a new background tab fails and breaks tab selection/switching

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: ke5trel, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

2 years ago
Twice on 48.0a2 I've tried to open an ordinary link in a new background tab with the middle mouse button and it fails to appear. Consequently tab selection becomes broken, no tab is visually selected and it is impossible to switch tabs by any means (mouse or keyboard). I found no way of resolving it other than restarting the browser.

Console errors:

> TypeError: browser is undefined TabState.jsm:104:1
> TypeError: aBrowser is undefined NetworkPrioritizer.jsm:101:5

 * #tabbrowser-tabs lists the new tab but it is hidden because it doesn't have the fadein="true" attribute. 
 * The original tab still has selected="true" attribute. 
 * No tab has visually-selected="true" attribute.

Updated

2 years ago
tracking-e10s: --- → ?
Any chance those "ordinary" links were invalid in any way? The symptoms sound like bug 1268285.
Flags: needinfo?(kestrel)
(Reporter)

Comment 2

2 years ago
The link was just an ordinary https://somewebsite.com and going through the same steps later multiple times I was unable to reproduce the bug.

I was able to reproduce Bug 1268285 and compare it with this one:

 * Same console error "browser is undefined TabState.jsm:104:1" but also other additional errors and exceptions.
 * Same invisible tab in #tabbrowser-tabs but has fewer attributes (eg no label).
 * Behaves somewhat normally until all tabs are closed, then it hits 100% CPU and browser content stuck on loading wheel.
 * Only happens with some invalid URIs.
 * Can always select tabs.
 * Can always create and close tabs.

So there are quite a few differences.
Flags: needinfo?(kestrel)
In a new window, follow the STR's in https://bugzilla.mozilla.org/show_bug.cgi?id=1268285#c7.  You end up with the funky browser, as jimm refers to it.  That window then behaves as this bug is reporting, you can add a tab, attempt to load a page, but it has content spinner forever. CPU is hogged at ~115%.  closing the affected window doesn't resolve the CPU use. The only way to recover, as reported, is to restart the browser.
Ouch, I had to force quit Nightly after shutdown as it did not proceed cleanly; Nightly (Not responding).

It is sort of odd steps to get into this state, but once in the funky browser state, it is really bad.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Tracy Walker [:tracy] from comment #3)
> In a new window, follow the STR's in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1268285#c7.  You end up with
> the funky browser, as jimm refers to it.  That window then behaves as this
> bug is reporting, you can add a tab, attempt to load a page, but it has
> content spinner forever. CPU is hogged at ~115%.  closing the affected
> window doesn't resolve the CPU use. The only way to recover, as reported, is
> to restart the browser.

As comment #2 noted, that bug and this bug end up with different symptoms, unless you close all the other tabs. Also, this bug is about tabs that do have a normal URI, and the root cause of bug 1268285 has been identified and is specifically about cases where E10SUtils.canLoadURIInProcess throws, which seems like it isn't the case here. As such, there's no guarantee that fixing that bug will fix this bug, and it would still be useful to have STR for this bug.

It seems like something further down the line in creating a tab and its browser is failing, but we don't know what. :-\
Kestrel, middle click seems to work fine.  Can you provide more explicit steps to reproduce?
Flags: needinfo?(kestrel)
(Reporter)

Comment 7

2 years ago
Unfortunately no STR at this time as it has only happened to me twice while opening a background tab with no obvious cause, hopefully it happens again under clearer circumstances. I have recently encountered Bug 1166351 which is similar but only affects new tabs.
Flags: needinfo?(kestrel)
The impact of bug 1166351 might be such that it affects new tabs sometimes, and pre-existing or background tabs other times - so the same bug might be affecting you there.

Updated

2 years ago
tracking-e10s: ? → +
Priority: -- → P2
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.