Closed Bug 1271153 Opened 5 years ago Closed 4 years ago

Adjust automation for new file mail/config/version_display.txt

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1175331 +++
Just like with Firefox, do the same with Thunderbird.
Attachment #8750120 - Flags: review?(rail)
Attachment #8750120 - Flags: review?(jlund)
See Also: → 1175331
Comment on attachment 8750120 [details] [diff] [review]
0001-Bug-1271153-Adjust-automation-for-new-file-mail-conf.patch

Sounds like we need to land version_disaplay.txt first to https://hg.mozilla.org/releases/comm-beta/file/tip/mail/config and https://hg.mozilla.org/releases/comm-esr45/file/tip/mail/config
Comment on attachment 8750120 [details] [diff] [review]
0001-Bug-1271153-Adjust-automation-for-new-file-mail-conf.patch

clearing r? while details (https://bugzilla.mozilla.org/show_bug.cgi?id=1271153#c2) are discussed
Attachment #8750120 - Flags: review?(jlund)
See comment #2
Flags: needinfo?(sledru)
Comment on attachment 8750120 [details] [diff] [review]
0001-Bug-1271153-Adjust-automation-for-new-file-mail-conf.patch

Review of attachment 8750120 [details] [diff] [review]:
-----------------------------------------------------------------

The patch lgtm, but we cannot land it until we get the in-tree files checked in.
Attachment #8750120 - Flags: review?(rail)
I will ping you once bug 1271151 is fixed!
Flags: needinfo?(sledru)
Comment on attachment 8750120 [details] [diff] [review]
0001-Bug-1271153-Adjust-automation-for-new-file-mail-conf.patch

The bug 1271151 landed!
(this can wait after the workweek)
Attachment #8750120 - Flags: review?(rail)
Since bug 1271151 had a string addition, that's not possible to land as such on esr45. You'll need to adjust this patch, or land a no-strings version of bug 1271151 for esr.
Right, thanks!
Attachment #8750120 - Attachment is obsolete: true
Attachment #8750120 - Flags: review?(rail)
Attachment #8762404 - Flags: review?(rail)
Comment on attachment 8762404 [details] [diff] [review]
0001-Bug-1271153-Adjust-automation-for-new-file-mail-conf.patch

The patch itself is correct, but automation will fail, because there is not version_display.txt in:

https://hg.mozilla.org/releases/comm-esr45/file/tip/mail/config
https://hg.mozilla.org/releases/comm-beta/file/tip/mail/config

We need the there before we land this patch.
Attachment #8762404 - Flags: review?(rail)
It won't land in esr45.
What do you recommend? 
* Wait until it lands in beta and apply the patch in both at this time
* Apply it on nightly now and do the same in beta when we can
(In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> What do you recommend? 
> * Wait until it lands in beta and apply the patch in both at this time
> * Apply it on nightly now and do the same in beta when we can

Can we uplift the patch in bug 1271151 to comm-beta? If not, we can just create version_display.txt now and land the buildbot patch - it won't hut having that file and not using it.
Probably. Magnus, would it be ok?
Flags: needinfo?(mkmelin+mozilla)
Don't see why not.
Flags: needinfo?(mkmelin+mozilla)
Rail, are you going to take care of that or do you want me to do it? Merci
Flags: needinfo?(rail)
The patch is assigned to you, this is why I didn't bothered myself to look at this ;)

I don't mind porting this, just throw it my way.
Flags: needinfo?(rail)
Can we move forward with this, as now version_display.txt is wrong after today's merges
(Oh, didn't realize it was just a few days ago you posted.)
Duplicate of this bug: 1292061
https://hg.mozilla.org/build/buildbot-configs/rev/06d19bac0eff19ccf2cf930aab5d0e8f5f8b13d3
[PATCH] Bug 1271153 - Adjust automation for the version_display.txt new file on tb r=rail
Fixed by hand in this comment for comm-central:
https://hg.mozilla.org/comm-central/rev/60e152b2aa6c


> Can we uplift the patch in bug 1271151 to comm-beta? If not, we can just
> create version_display.txt now and land the buildbot patch - it won't hut
> having that file and not using it.
Rail, is it going to fail in beta if the file doesn't exist?
Flags: needinfo?(rail)
https://hg.mozilla.org/releases/comm-aurora/rev/a08bdac74f35aef9b0b56e0f8d025be5da0cb449
Bug 1271153 - Update the version_display. Should be managed by automation in the future a=sylvestre DONTBUILD
(In reply to Sylvestre Ledru [:sylvestre] from comment #21)
> Fixed by hand in this comment for comm-central:
> https://hg.mozilla.org/comm-central/rev/60e152b2aa6c
> 
> 
> > Can we uplift the patch in bug 1271151 to comm-beta? If not, we can just
> > create version_display.txt now and land the buildbot patch - it won't hut
> > having that file and not using it.
> Rail, is it going to fail in beta if the file doesn't exist?

yup, we should add that file
Flags: needinfo?(rail)
https://hg.mozilla.org/releases/comm-beta/rev/f432b2d0ec76e40131940aa710954c8baa5801bd
Bug 1271153 -Add the file version_display.txt, not going to be used by the product but this will simplify the automation r=rail a=sylvestre
Sylvestre, anything left here?
Flags: needinfo?(sledru)
I think this is fixed now
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(sledru)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.