[e10s] Assertion failure: mChildList.Length() == 0 and crash | runner.py | application crashed [@ nsDocShell::SetOriginAttributes]

RESOLVED DUPLICATE of bug 1250033

Status

()

Core
Document Navigation
--
critical
RESOLVED DUPLICATE of bug 1250033
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: allstars)

Tracking

({crash, intermittent-failure, regression})

49 Branch
crash, intermittent-failure, regression
Points:
---

Firefox Tracking Flags

(e10s?, firefox49 fixed)

Details

(crash signature)

Our Firefox UI functional tests crashed while running the test .py

https://treeherder.mozilla.org/logviewer.html#?job_id=27475513&repo=mozilla-inbound#L53192-L53209

Before the crash the following assertion is shown:

Assertion failure: mChildList.Length() == 0, at /home/worker/workspace/build/src/docshell/base/nsDocShell.cpp:14082 

Crash:

 07:37:05     INFO - PROCESS-CRASH | runner.py | application crashed [@ nsDocShell::SetOriginAttributes]

 07:37:05     INFO - Crash dump filename: /home/worker/workspace/build/tmpEQDTiE.mozrunner-1462778503/minidumps/023d12ba-98e2-7a14-09752b71-062bc3ed.dmp

 07:37:05     INFO - Operating system: Linux

 07:37:05     INFO -                   0.0.0 Linux 3.13.0-79-generic #123-Ubuntu SMP Fri Feb 19 14:27:58 UTC 2016 x86_64

 07:37:05     INFO - CPU: amd64

 07:37:05     INFO -      family 6 model 62 stepping 4

 07:37:05     INFO -      1 CPU

 07:37:05     INFO - 

 07:37:05     INFO - Crash reason:  SIGSEGV

 07:37:05     INFO - Crash address: 0x0

 07:37:05     INFO - 

 07:37:05     INFO - Thread 0 (crashed)

 07:37:05     INFO -  0  libxul.so!nsDocShell::SetOriginAttributes [nsDocShell.cpp:e5e098755b52 : 14082 + 0x11]

 07:37:05     INFO -     rbx = 0x00007fff3aaad0e8   r12 = 0x0000000000000000

 07:37:05     INFO -     r13 = 0x00007ff354d18000   r14 = 0x00007ff35e8ecc00

 07:37:05     INFO -     r15 = 0x00007fff3aaad20c   rip = 0x00007ff3704c72d6

 07:37:05     INFO -     rsp = 0x00007fff3aaad0d0   rbp = 0x00007fff3aaad0d0

07:37:05 INFO - Found by: given as instruction pointer in context
Actually this only affects e10s and has been caused by the landing of the patch on bug 1250033.
tracking-e10s: --- → ?
Flags: needinfo?(allstars.chh)
Keywords: regression
Summary: Assertion failure: mChildList.Length() == 0 and crash | runner.py | application crashed [@ nsDocShell::SetOriginAttributes] → [e10s] Assertion failure: mChildList.Length() == 0 and crash | runner.py | application crashed [@ nsDocShell::SetOriginAttributes]
Blocks: 1250033
(Assignee)

Comment 2

2 years ago
Sorry for causing trouble :(
Just learned from Tomcat that this is a tier-3 test so I didn't notice it in the first place.
I'll check this.
Assignee: nobody → allstars.chh
Flags: needinfo?(allstars.chh)
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1250033
Tracking in the duplicate bug, which just got backed out and isn't resolved.
Fixed in 49 in the duplicate.
status-firefox49: affected → fixed
You need to log in before you can comment on or make changes to this bug.