Closed Bug 1271277 Opened 4 years ago Closed 4 years ago

Cannot add enterprise certificate to global cert8.db

Categories

(Firefox :: Untriaged, defect)

46 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1269706

People

(Reporter: post, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

I copy file cert8.db (with our company certificate CA included) to
C:\Program Files\Mozilla Firefox\browser\defaults\profile\
(64-bit Firefox version) and this file is not coppied to user profile, when user starts Firefox for the first time.


Actual results:

User starts Firefox and try to search anything, Firefox shows error of insecure HTTPS connection.
It is because all our users are behind company firewall, and SSL connections (except banks, and SSL client-login pages) are checked for antivirus issues etc.


Expected results:

File cert8.db from C:\Program Files\Mozilla Firefox\browser\defaults\profile\
should be coppied to user profile, so he would be able to visit SSL sites, that
are flowing via our firewall.
Our's firewall SSL CA certificate is added to cert8.db, that is "global" to all users of the PC.
Adding that manually by user is less secure (they would need to know it is proper certificate), and will make impression, that PC is not enterprise grade.

This bug was introduced in Firefox version 46. It worked in 45.
If there is other enterprise ready solution to submit cert8.db, please let me know.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269706
You need to log in before you can comment on or make changes to this bug.