Closed Bug 1271368 Opened 4 years ago Closed 4 months ago

nav_help.xhtml: "Searching from the Location Bar" is outdated

Categories

(SeaMonkey :: Help Documentation, defect)

Unspecified
All
defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ affected, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.75
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + affected
seamonkey2.57esr ? affected

People

(Reporter: RainerBielefeldNG, Assigned: nunojsg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.3)

Attachments

(5 files, 1 obsolete file)

Steps how to reproduce with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

1. Browser → F1
   » Help appears
2. Type search string "Searching" → Click hit "Searching the Web" → 
   in TOC click "Fast Searches"
   » Related Help appears
3. compare "Searching from the Location Bar" with reality
   Bug: bad advice
  
Things need to be improved:
a) Screenshot: "Bookmark This Page" Icon at the right of location bar
   is missing (or is this a non-standard-preference of my SM?)
b) Screenshot: Search-button is not part of Location bar, but 
   completely independent 
c) "Double-click in the Location Bar to select the current text.": At
    least my SM selects words in URL with double click, 
    complete URL will be selected with single click
d) "the results are saved in Sidebar's Search tab until ..."
   I don't understand that, I can't see any influence of the search
   to the Search Tab in Sidebar.
e) It might be useful to split away every single a ... d (or even more
   items) into separate Bugs after Confirmation here.
This is a very old picture. Also this looks like the SeaMonkey Modern Theme.
a) Use a recent SeaMonkey version. Switch theme to Modern. Take a snapshot of the relevant part of the screen. Attach here for review.
b) Now "Search" and "Go" buttons are separate and independent. Might need some new help text.
c) Change to "Select all the text in the Location Bar"
d) Remove this text as we don't have the Advanced search sidebar any more.
e) Sounds reasonable.
want to work on this bug
Amit,

just attach a patch and ask Philip Chee or Iann_bugzilla for review.
(In reply to Frank-Rainer Grahl from comment #3)
> Amit,
> 
> just attach a patch and ask Philip Chee or Iann_bugzilla for review.

where I can find nav_help.xhtml file so that I can fix the issue and create a patch
Amit,

you need to checkout the SeaMonkey source tree using mercurial. You might also install a development environment so that you can test your changes before uploading them here. 

Which operation system?

Outdated procedure here:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_SeaMonkey_build

If you want to follow this thru better contact me via email.

FRG
(In reply to Amit singh from comment #4)
> where I can find nav_help.xhtml file 

<https://hg.mozilla.org/comm-central/file/tip/suite/locales/en-US/chrome/common/help/nav_help.xhtml>!
Some more information you can find in the wiki at <https://wiki.mozilla.org/SeaMonkey/FAQ#How_To_Start_Contributing_Code>
Is this bug still open? If yes,I would like to work on it.
Flags: needinfo?(RainerBielefeldNG)
yashri412,

yes the bug is still open. Be advised that the help in the tree is currently broken. I suggest checking out comm-esr52 and fix it there. 

If you hava a patch ask me for review. I will assign the bug then to you.

Let me know if you need more information.
Flags: needinfo?(RainerBielefeldNG)
(In reply to Frank-Rainer Grahl (:frg) from comment #8)
> yashri412,
> 
> yes the bug is still open. Be advised that the help in the tree is currently
> broken. I suggest checking out comm-esr52 and fix it there. 
> 
> If you hava a patch ask me for review. I will assign the bug then to you.
> 
> Let me know if you need more information.

Thanks a lot. This is my first time. Can you guide me through how to do it, please?
Sure. Please send me an email. I am a little busy till Monday but will try.
Here is my email -
prateeksurana3255@gmail.com
Can you please provide me with a link to docs for first-timers, so that I can get started with creating a patch.
Flags: needinfo?(frgrahl)
I have installed mercurial on my system and cloned the repo
prateeksurana3255 I just sent you an email with some information.
Flags: needinfo?(frgrahl)
Thanks, got the mail. I will notify you as soon as I have set up the development environment successfully.
I am also interested in fixing this bug .So please mail me paras.lakhani.cs.2016@miet.ac.in so that i fix this bug
Hae is this bug open?If so am a first timer need guidance on how to go about it
ijay,

are you fmailiar with SeaMonkey? You need to set up a build environment for it. You can follow this guide to get the source. 

https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Source_Code/Getting_comm-central

comm-central is currently broken. I suggest using comm-esr52

https://hg.mozilla.org/releases/comm-esr52/

Hi, I am an Outreachy applicant. Can I take up this issue?

rohirakirti are you familiar and able to build SeaMonkey?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: nav_help.xhtml: "Searching from the Location Bar" needs review → nav_help.xhtml: "Searching from the Location Bar" is outdated
Whiteboard: [easyconfirm][good first bug] → [seamonkey-good-first-bug]

I am not able to build Seamonkey due to shortage of system requirements. I am having a dual booted system with 4GB ram and it is showing errors because of that.

Keywords: good-first-bug
Whiteboard: [seamonkey-good-first-bug]

Kohei, why did you change the Whiteboard to a keyword. Did this cause a problem? Was not a mistake. With good-first-bugs we usually attract new devs looking for mozilla bugs only?

Flags: needinfo?(kohei.yoshino)
Flags: needinfo?(kohei.yoshino)

Yes I see that this applies to mozilla but it just wastes our time.

Keywords: good-first-bug

c) probably depends on browser.urlbar.clickSelectsAll, which has a different default value for non-MacOS UNIX-like systems, see
https://hg.mozilla.org/comm-central/file/tip/suite/app/profile/suite-prefs.js#l793

The text mentioned in d) was removed in https://hg.mozilla.org/comm-central/rev/6b8514a38d06

For a) and b), the screenshot still needs to be updated.

a) and b): A screenshot without the search button and with the bookmark icon.

a) and b): A search button screenshot.
(I guess this could also replace the use of search_personal_toolbar.gif in this help file?)

Attachment #9149147 - Flags: feedback?(iann_bugzilla)
Assignee: nobody → nunojsg
Status: NEW → ASSIGNED
Comment on attachment 9149147 [details] [diff] [review]
patch for nav_help.xhtml and new screenshots v1

Looks good, as you mentioned on irc, need to remove the old images if they're not in use.
Attachment #9149147 - Flags: feedback?(iann_bugzilla) → feedback+

These two images don't seem to be used anywhere else, so this deletes them (and updates suite/locales/jar.mn).

Attachment #9149147 - Attachment is obsolete: true
Attachment #9149367 - Flags: review?(iann_bugzilla)
Comment on attachment 9149367 [details] [diff] [review]
patch for nav_help.xhtml and new screenshots v2

>+++ b/suite/locales/en-US/chrome/common/help/nav_help.xhtml
>-      <li>Click the Search button.</li>
>-      <li>Click <q>Search Google for <q>baby doll</q></q> at the bottom of the
>-        drop-down list in the Location Bar. (Your default search engine may be
>-        different.)
>+      <li>Click the Search button <img src="images/search_navigation_toolbar.png"
>+    width="73" height="21" alt="search button"/>.</li>
Nit: indentation.
>+      <li>Click <q>Search DuckDuckGo for <q>baby doll</q></q> at the bottom of
>+        the drop-down list in the Location Bar. (Your default search engine may
>+        be different.)

r/a=me with that fixed.
Attachment #9149367 - Flags: review?(iann_bugzilla)
Attachment #9149367 - Flags: review+
Attachment #9149367 - Flags: approval-comm-release+
Attachment #9149367 - Flags: approval-comm-esr60+

Hi, are you also working on which other locales also need this fixing?

Flags: needinfo?(nunojsg)

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/fdd49148dcc1
Update help for Location bar search. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

An initial patch for l10n.

For files in English, this does the same changes (except the search engine name if the default is Google). For translated nav_help.xhtml files, this only adds new screenshots (with the search expression used in the translation and with the localized search button).

Flags: needinfo?(nunojsg)
Attachment #9150914 - Flags: feedback?(iann_bugzilla)
Comment on attachment 9150914 [details] [diff] [review]
l10n patch (nav_help.xhtml, update screenshots) v1

[Triage Comment]
LGTM r/a=me
Attachment #9150914 - Flags: review+
Attachment #9150914 - Flags: feedback?(iann_bugzilla)
Attachment #9150914 - Flags: approval-comm-release+
Attachment #9150914 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.3

When I replaced the use of search_personal_toolbar.gif with search_navigation_toolbar.png in en-US/comm-central nav_help.xhtml, I forgot to update the width and height attributes. This patch does that.

Attachment #9154777 - Flags: review?(iann_bugzilla)
Comment on attachment 9154777 [details] [diff] [review]
en-US nav_help.xhtml: update search button dimensions

LGTM
Attachment #9154777 - Flags: review?(iann_bugzilla)
Attachment #9154777 - Flags: review+
Attachment #9154777 - Flags: approval-comm-release+
Attachment #9154777 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/19b987f6709b
nav_help.xhtml: Update search button dimensions. r=frg
You need to log in before you can comment on or make changes to this bug.