Closed Bug 1271374 Opened 4 years ago Closed 3 years ago

Intermittent browser_ext_tabs_executeScript_runAt.js | Error: Error: Max tries exceeded :: again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:12:31

Categories

(WebExtensions :: Untriaged, defect, P3)

defect

Tracking

(firefox49 fixed, firefox50 fixed, firefox51 fixed)

RESOLVED FIXED
mozilla51
Tracking Status
firefox49 --- fixed
firefox50 --- fixed
firefox51 --- fixed

People

(Reporter: aryx, Assigned: kmag)

References

Details

(Keywords: intermittent-failure, Whiteboard: triaged)

https://treeherder.mozilla.org/logviewer.html#?job_id=27510015&repo=mozilla-inbound

16:41:15     INFO -  144 INFO Got states: complete,complete,complete
16:41:15     INFO -  145 INFO TEST-PASS | browser/components/extensions/test/browser/browser_ext_tabs_executeScript_runAt.js | document_end state is valid: complete -
16:41:15     INFO -  146 INFO TEST-PASS | browser/components/extensions/test/browser/browser_ext_tabs_executeScript_runAt.js | document_idle state is valid: complete -
16:41:15     INFO -  147 INFO TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_tabs_executeScript_runAt.js | Error: Error: Max tries exceeded :: again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:12:31
16:41:15     INFO -  again/<@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:59:18
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*again@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:26:14
16:41:15     INFO -  promise callback*background@moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:64:5
16:41:15     INFO -  @moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:1:11
16:41:15     INFO -   -
16:41:15     INFO -  Stack trace:
16:41:15     INFO -  chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:testHandler:59
16:41:15     INFO -  chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:testResult:69
16:41:15     INFO -  chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:SpecialPowersAPI.prototype.loadExtension/listener:1959
16:41:15     INFO -  chrome://mochikit/content/tests/SimpleTest/ChromePowers.js:ChromePowers.prototype._sendReply:35
16:41:15     INFO -  chrome://mochikit/content/tests/SimpleTest/SpecialPowersObserverAPI.js:SpecialPowersObserverAPI.prototype._receiveMessageAPI/resultListener:538
16:41:15     INFO -  resource://devtools/shared/event-emitter.js:EventEmitter_emit:163
16:41:15     INFO -  resource://gre/modules/Extension.jsm:emit:1275
16:41:15     INFO -  chrome://extensions/content/ext-test.js:.test.fail:48
16:41:15     INFO -  resource://gre/modules/Extension.jsm:callFunctionNoReturn:558
16:41:15     INFO -  resource://gre/modules/Schemas.jsm:inject/stub:1036
16:41:15     INFO -  moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:null:71
16:41:15     INFO -  Not taking screenshot here: see the one that was previously logged
16:41:16     INFO -  148 INFO TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_tabs_executeScript_runAt.js | executeScript-runAt -
16:41:16     INFO -  Stack trace:
16:41:16     INFO -  chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:testResult:66
16:41:16     INFO -  chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:SpecialPowersAPI.prototype.loadExtension/listener:1959
16:41:16     INFO -  chrome://mochikit/content/tests/SimpleTest/ChromePowers.js:ChromePowers.prototype._sendReply:35
16:41:16     INFO -  chrome://mochikit/content/tests/SimpleTest/SpecialPowersObserverAPI.js:SpecialPowersObserverAPI.prototype._receiveMessageAPI/resultListener:538
16:41:16     INFO -  resource://devtools/shared/event-emitter.js:EventEmitter_emit:163
16:41:16     INFO -  resource://gre/modules/Extension.jsm:emit:1275
16:41:16     INFO -  chrome://extensions/content/ext-test.js:.test.notifyFail:40
16:41:16     INFO -  resource://gre/modules/Extension.jsm:callFunctionNoReturn:558
16:41:16     INFO -  resource://gre/modules/Schemas.jsm:inject/stub:1036
16:41:16     INFO -  moz-extension://2d773e27-af9f-4234-a7f9-bb568551b729/%7Ba0805117-b7c4-4a6b-846d-950df6e12de8%7D.js:null:72
Priority: -- → P3
Whiteboard: triaged
Flags: needinfo?(kmaglione+bmo)
https://hg.mozilla.org/integration/fx-team/rev/aee75e50fbc15694bbe48724eb28dea184ef985e
Bug 1271374: Add Cache-Control: no-cache to the delayed load SJS page. r=me
Duplicate of this bug: 1274771
https://hg.mozilla.org/mozilla-central/rev/aee75e50fbc1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Flags: needinfo?(kmaglione+bmo)
This is still happening.
Assignee: nobody → kmaglione+bmo
Status: RESOLVED → REOPENED
Flags: needinfo?(kmaglione+bmo)
Resolution: FIXED → ---
Target Milestone: mozilla49 → ---
Flags: needinfo?(kmaglione+bmo)
https://hg.mozilla.org/mozilla-central/rev/bd37925de22b
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.