[e10s] Easy Screenshot add-on not functional when e10s is enabled

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Grover-QA, Assigned: hectorz)

Tracking

49 Branch
All
Unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox49 affected)

Details

(Whiteboard: [screenshot] triaged impactse10s)

(Reporter)

Description

3 years ago
The Easy Screenshot add-on is not functional when e10s is enabled. The add-on works as intended when e10s is disabled, and it does not matter whether Shim is enabled or not.

This is affecting the following user agents:
(Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0
(Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
(X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0

Steps to Reproduce:
Pre-Requisite: Start Firefox with a clean profile
1. Install the Easy Screenshot add-on https://addons.mozilla.org/addon/easyscreenshot
2. Restart the Browser
3. Access http://www.nytimes.com/
4. Click the add-on icon 
5. Select an option from the drop-down window

Expected Results:
The add-on should execute the functions as designed when the user selects from the drop down window.

Actual Results:
When e10s is enabled, there are two different errors. When shim is enabled, the functions from the drop-down window do not work as intended. You can drag the marker across the screen, but no option to take a screenshor appears. When shim is disabled, the addon button does not function entirely.
(Reporter)

Updated

3 years ago
Blocks: 905439
Blocks: 905436
tracking-e10s: ? → +

Comment 1

3 years ago
Is there any chance you'd consider migrating this to webextensions?  We'd definitely check if something is missing....

Jorge is looking up for the person he spoke with in London from MozOnline
Flags: needinfo?(jorge)
Priority: -- → P1
Whiteboard: [screenshot] triaged

Updated

3 years ago
Whiteboard: [screenshot] triaged → [screenshot] triaged impactse10s
I think it was Hector I talked to. Hector, can you share your plans for e10s compatibility?
Flags: needinfo?(jorge) → needinfo?(bzhao)
(Assignee)

Comment 3

3 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> I think it was Hector I talked to. Hector, can you share your plans for e10s
> compatibility?

The e10s compatibilty works of our extensions started right after London. I'm currently working on bug fixes of {cehomepage,cpmanager}@mozillaonline.com, easyscreenshot will be the next (later this week or next week, I guess).

(In reply to :shell escalante from comment #1)
> Is there any chance you'd consider migrating this to webextensions?  We'd
> definitely check if something is missing....
> 

My original plan was just updating the current XUL overlay extension. Now that you've mentioned it, easyscreenshot is actually one of our extensions which doesn't involve too much XPCOM magics, it's a good chance for me to have a look at the WebExtensions APIs.
Flags: needinfo?(bzhao)

Updated

3 years ago
Priority: P1 → --

Updated

2 years ago
Blocks: 1287157
Any update on this? as E10S is in the release channel, I am badly missing the add-on
(Assignee)

Comment 5

2 years ago
A new version was uploaded to and approved on AMO. It's a hybrid extension for the migration of editor prefs, and should be e10s compatible. I forgot to add mpc=true in its install.rdf, I'll do so with the next update, which depends on users' feedback on this version.
(Assignee)

Comment 6

2 years ago
A new version was uploaded and approved with mpc=true set, resolving this bug as fixed. Thanks for all your patience.
Assignee: nobody → bzhao
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.