Closed Bug 1271580 Opened 4 years ago Closed 2 years ago

When opening multiple (>12) tabs from a third party app the app crashes.

Categories

(Firefox for Android :: General, defect)

47 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox47 --- affected
fennec + ---

People

(Reporter: asimonca, Assigned: droeh)

Details

(Keywords: crash)

Crash Data

Steps:
1. Start with a clean profile.
2. Open multiple tabs from another app. (i.e. Gmail).

Expected: All tabs load and work properly.

Actual: A crash occurs.

Note: When trying to reproduce this bug on Nightly a different Crash Signature is generated, related to bug: 1257387

This bug was filed from the Socorro interface and is 
report bp-4e446a28-1b2a-452a-86aa-2ab1c2160510.
=============================================================
tracking-fennec: --- → ?
Assignee: nobody → droeh
tracking-fennec: ? → +
If this is an OOM crash, then a simple solution could be to do what we already do for session restoring on startup: only load the tab that is going to be the foreground tab directly and create all other tabs as delay loaded zombie tabs.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
I also implemented my suggestion from comment 1 in bug 1415277, which should have helped here.
You need to log in before you can comment on or make changes to this bug.