Closed Bug 1271604 Opened 4 years ago Closed 3 years ago

Crash in OOM | unknown | js::AutoEnterOOMUnsafeRegion::crash | JS::Zone::getUniqueIdInfallible

Categories

(Core :: JavaScript: GC, defect, critical)

48 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1260785

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

This bug was filed from the Socorro interface and is 
report bp-c7c662d8-7e6d-498a-b02f-ab0b82160510.
=============================================================

Seen while looking at 48 crash stats. #14 in the last 7 days on 48.0a2. Highest concentration of crashes on Win7 but crashes are seen across the full Windows spectrum. Top URL is facebook.com.

Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	js::AutoEnterOOMUnsafeRegion::crash(char const*) 	js/src/jscntxt.cpp:1236
1 	xul.dll 	JS::Zone::getUniqueIdInfallible(js::gc::Cell*) 	js/src/gc/Zone.h:423
2 	xul.dll 	JS::Zone::getHashCodeInfallible(js::gc::Cell*) 	js/src/gc/Zone.h:416
3 	xul.dll 	JSStructuredCloneWriter::write(JS::Handle<JS::Value>) 	js/src/vm/StructuredClone.cpp:1405
4 	xul.dll 	JSStructuredCloneWriter::write(JS::Handle<JS::Value>) 	js/src/vm/StructuredClone.cpp:1405
5 	xul.dll 	WriteStructuredClone(JSContext*, JS::Handle<JS::Value>, unsigned __int64**, unsigned int*, JSStructuredCloneCallbacks const*, void*, JS::Value) 	js/src/vm/StructuredClone.cpp:391
6 	xul.dll 	JSAutoStructuredCloneBuffer::write(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JSStructuredCloneCallbacks const*, void*) 	js/src/vm/StructuredClone.cpp:2352
7 	xul.dll 	mozilla::dom::StructuredCloneHolderBase::Write(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>) 	dom/base/StructuredCloneHolder.cpp:188
8 	xul.dll 	xpc::StackScopedClone(JSContext*, xpc::StackScopedCloneOptions&, JS::MutableHandle<JS::Value>) 	js/xpconnect/src/ExportHelpers.cpp:262
9 	xul.dll 	nsXPCComponents_Utils::CloneInto(JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JSContext*, JS::MutableHandle<JS::Value>) 	js/xpconnect/src/XPCComponents.cpp:3289
10 	xul.dll 	xul.dll@0x255dcc7
Terrence, is there any chance we could annotate this with the allocation size? I guess the more reasonable way to do that would be to add some kind of infallible add to the map structure.
Flags: needinfo?(terrence)
It would be good to know if the table has a reasonable size or if it is getting really huge.
This sounds like the same thing as bug 1260785, so I'll just dupe it over there.
Crash Signature: [@ OOM | unknown | js::AutoEnterOOMUnsafeRegion::crash | JS::Zone::getUniqueIdInfallible]
Flags: needinfo?(terrence)
Per comment #3, I'm duping this bug to bug #1260785.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260785
You need to log in before you can comment on or make changes to this bug.