[Windows 10] Remove the Titlebar Solid Light Blue color, Breaks Windows 10's DWM Titlebar coloring feature.

RESOLVED WONTFIX

Status

Thunderbird
OS Integration
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: PeterSvP, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8750746 [details]
Win10issues.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Steps to reproduce:

Get Windows 10.
Install Glass8 from Glass8.eu.
Start Thunderbird. 


Actual results:

Notice that the Titlebar is not rendered via the Aero Glass Effect on Thunderbird 45, it's solid blue instead.


Expected results:

The titlebar whould be rendered ad before, respecting the DWM Glass Frame, even if originally not supported on Windows 10, it is respected by DWM and Glass8.eu's DWM.
We can't support every 3rd party extension of a OS.

You can try either to set mail.tabs.drawInTitlebar to false or to add in userChrome.css something like:

      #messengerWindow {
        background-color: transparent !important;
      }

but I don't know if there are other things which needs tweaks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

2 years ago
Can you send me the patch / Revision that actually made this UI change? I will then probably take it on my own :) Is it only Windows 10-specific?
(Reporter)

Comment 3

2 years ago
Code like this worked for me.
#messengerWindow {
    background-color: rgba(100,190,255, 0.3) !important;
}

However, Seriously, you are even overriding the accent color set within Windows 10 itself in Settings (Windows 10 feature itself) not just custom DWMs. 

Better, leave it as it was before. Do not override the color set via DWM. Leave it to DWM to draw the titlebar, not because somebody said himself "Hey, this white is ugly, lets make it blue.

Now, try following NEW repro:

Get windows 10. Clean. No custom DWMs.
Get Thunderbird.
Go to PC Settings, PErsonalizatoion, Color.
Turn on the "Show Color on Start, taskbar, action center and Title bar".
Set the Color to RED. 
Notice how ugly is Thunderbird Window then, with the red border and light bluish titlebar.

Reopened, thanks
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 4

2 years ago
Created attachment 8750830 [details]
Setting Windows Color to RED and enabling DWM's Titlebar coloring option leads to complete ugliness.

Setting Windows Color to RED and Enabling DWM's Titlebar coloring option in PC Settings on unmodded windows leads to complete ugliness.
(Reporter)

Updated

2 years ago
Summary: [Windows 10] Add option to disable the newest Titlebar UI Solid Color change, breaks if custom DWM is installed → [Windows 10] Remove the Titlebar Solid Light Blue color, Breaks Windows 10's DWM Titlebar coloring feature.
(In reply to Richard Marti (:Paenglab) from comment #1)
> We can't support every 3rd party extension of a OS.
> 
> You can try either to set mail.tabs.drawInTitlebar to false or to add in
> userChrome.css something like:
> 
>       #messengerWindow {
>         background-color: transparent !important;
>       }
> 
> but I don't know if there are other things which needs tweaks.

The patch was such a CSS change.

We need to set a background color because we have to use the Firefox implementation to draw in titlebar. Without the background color we have not wanted effects.

When you want a change in this, please file a bug on Firefox. We then follow their implementation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

2 years ago
I have noticed redrawing issues on titlebar buttons in both Firefox / Thunderbird with the transparent css. however, gray color is neutral to any window border, I'd prefer Firefox's Gray titlebar over Thunderbird's bluish one.
You need to log in before you can comment on or make changes to this bug.