Crash if switching theme twice

RESOLVED DUPLICATE of bug 126692

Status

--
critical
RESOLVED DUPLICATE of bug 126692
17 years ago
11 years ago

People

(Reporter: spamcop, Assigned: asa)

Tracking

({crash, stackwanted, verifyme})

Trunk
x86
Windows 98
crash, stackwanted, verifyme

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8+) Gecko/20020221
BuildID:    2002022103

When I switch from modern to classic theme, using the view menu and then switch
back to modern theme via the view menu, Mozilla crashes. If I start-up in
classic skin and switch to modern skin, it doesn't crash, but if I then switch
to classic and back to modern, it will crash again.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla and change to modern skin (if not already active)
2. Switch to classic skin via view menu
3. Switch to modern skin via view menu

Actual Results:  CRASH

Expected Results:  Theme switches as desired
(Reporter)

Comment 1

17 years ago
Created attachment 70857 [details]
Talkback Information

Maybe this will help to find the problem.

Comment 2

17 years ago
You should provide a talkback ID instead.
(Reporter)

Comment 3

17 years ago
1) What is a talkback ID?
2) What do you need it for?
(Reporter)

Comment 4

17 years ago
Okay, here is your Talkback ID: TB3223580W

Just a stupid question: I don't know what happens to my report if it's sent
through this Talkback tool, maybe it's sent to some person or to some server,
that will then somehow process the data of the incident, whatever, where is the
problem of forwarding my attachment to this address and that way receive the
information you expect of such an ID?

Comment 5

17 years ago
Marking as dupe of bug 126692. Reporter: If you disagree, please reopen this bug.

*** This bug has been marked as a duplicate of 126692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → Skinability
Resolution: --- → DUPLICATE

Comment 6

17 years ago
the problems:
1. we have no parser for raw talkback data. which means what you uploaded is A 
useless and B a big waste of space
2. afaik we have no easy way to convert the talkback data into a talkback stack
3. what's the point? talkback.exe gives you the incident number which is nice 
and compact and references all the information we need

as for what talkback does if left unattended, it gets a stack trace which will 
end up in npm.crash-data and if the number of hits for a stack is high enough, 
someone will probably file a bug based on the stack.

however, it's much better if you have steps to reproduce to file a bug here 
with your talkback incident id so that any random developer (or yourself) can 
see the stack trace and do something based on it + your steps to reproduce.
Keywords: crash, stackwanted, verifyme
nsTemplateRule::GetContent
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsTemplateRule.cpp, line 63]
nsStyleContext::Destroy
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 1279]
nsStyleContext::Release
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 187]
nsSupportsHashtable::ReleaseElement
[d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 860]
0x025b3010
nsSupportsHashtable::~nsSupportsHashtable
[d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 866]
nsSupportsHashtable::`scalar deleting destructor'
nsOutlinerStyleCache::Clear
[d:\builds\seamonkey\mozilla\layout\xul\base\src\outliner\src\nsOutlinerBodyFrame.h,
line 248]
nsOutlinerBodyFrame::ClearStyleAndImageCaches
[d:\builds\seamonkey\mozilla\layout\xul\base\src\outliner\src\nsOutlinerBodyFrame.cpp,
line 3115]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5256]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
PresShell::ReconstructStyleData
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5327]
PresShell::StyleSheetRemoved
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5371]
nsXULDocument::UpdateStyleSheets
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 1344]
nsChromeRegistry::RefreshWindow
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 1334]
nsChromeRegistry::RefreshSkins
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 1161]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3417]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1218]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2210]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3453]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3472]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3472]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3472]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3472]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6053]
nsMenuFrame::Execute
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 1640]
nsMenuFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 466]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6022]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5928]
nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2043]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 306]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1863]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 860]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 877]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4619]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4869]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3544]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1122]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00648c16 

Comment 8

17 years ago
Turns out this is a duplicate of topcrash bug 116038.
Same stack in http://bugzilla.mozilla.org/show_bug.cgi?id=116038#c33
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.