Closed Bug 1271642 Opened 5 years ago Closed 5 years ago

[Linux] Audio is not played back on gum test page

Categories

(Core :: Audio/Video: cubeb, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: phorea, Unassigned)

References

()

Details

[Note]:
- Issue doesn't reproduce under Win 10 64-bit and Mac OS X 10.11

[Affected versions]:
- Firefox 46 beta 4
- Aurora 48.0a2 2016-05-09
- Nightly 49.0a1 2016-05-10

[Affected platforms]:
- Ubuntu 14.04 LTS

[Steps to reproduce]:
1. Open http://mozilla.github.io/webrtc-landing/gum_test.html
2. Select Audio and choose to share the microphone 

[Expected result]:
- The sound is properly played back.

[Actual result]:
- No sound is played. (The microphone works with other apps)

[Regression range]:
- I could reproduce this on Firefox 45.0.2 so it's not a recent regression. I will search again tomorrow to see if this regressed in older builds.
(In reply to Petruta Rasa [QA] [:petruta] from comment #0)
> [Regression range]:
> - I could reproduce this on Firefox 45.0.2 so it's not a recent regression.
> I will search again tomorrow to see if this regressed in older builds.

I'm adding the keywords until we know for sure what caused this.
See Also: → 1269030
I'm removing the keywords as this reproduces on 36.0.1 (first release where the microphone can be shared) and 42.0 (first release with audio time counter).
Very like the microphone being tested is not supported by the libcubeb library (and has never been supported).  Can you tell us exactly what microphone/audio input you're using and what the pulse panel shows for audio input?  Does the same microphone/audio input work with the Chrome browser on Linux (for WebRTC calls)?  

If you can also get logs from Fx47 with NSPR_LOG_MODULES=MediaManager:4,GetUserMedia:4 NSPR_LOG_FILE=some_tmp_file, that would help (the same logs from 48 might help as well).  See https://wiki.mozilla.org/Media/WebRTC/Logging

Thanks.
Rank: 35
Component: Audio/Video: Playback → Audio/Video: cubeb
Flags: needinfo?(petruta.rasa)
Priority: -- → P3
(In reply to Petruta Rasa [QA] [:petruta] from comment #2)
> I'm removing the keywords as this reproduces on 36.0.1 (first release where
> the microphone can be shared) and 42.0 (first release with audio time
> counter).

While the current gum test page may not work before 36, mozGetUserMedia has worked (and the then-current gum_test patch) since around Firefox 22
Turned out it was my system that had issues, as I've got the same results with 4 different headsets (Chrome too). After some updates, installs, reboots etc I could clearly hear the audio output.

Sorry for the trouble.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(petruta.rasa)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.