Logviewer shows "The log no longer exists or has expired" even it is present

RESOLVED DUPLICATE of bug 1275796

Status

RESOLVED DUPLICATE of bug 1275796
2 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
Today I have seen that the log viewer declines to open a log because it thinks that it is no longer existent or has been expired. That happens 5 days after the report has been sent to Treeherder. Also the underlying report still exists:

https://treeherder.mozilla.org/logviewer.html#?job_id=20401993&repo=try#L34722

https://public-artifacts.taskcluster.net/ezYec3LDRQmhvIeF88GPcw/0/public/logs/live_backing.log

Comment 1

2 years ago
When opening the link above from Bugzilla, the resultant URL shown in the location bar is:
https://treeherder.mozilla.org/logviewer.html#?job_id=20401993&repo=try#L34722
...and the log opens fine.

When following the same link, but from my bugmail in GMail, results in:
https://treeherder.mozilla.org/logviewer.html#?job_id=20401993&repo=try%23L34722
...which displays the "The job does not exist or has expired".

Having two hashes in the URL probably doesn't help.

Comment 2

2 years ago
Ah the STR were incomplete. (Which combined with the Gmail link breaking made me think comment 0 had just experienced the same from gmail).

It's:
1) Visit https://treeherder.mozilla.org/logviewer.html#?job_id=20401993&repo=try#L34722
2) Click an error summary section to cause that part to load in the main panel

Expected:
Loads if the log exists on FTP/wherever (existence can be verified by following the "raw log" link at the top).

Actual:
"The log no longer exists or has expired" shown in the main panel

Comment 3

2 years ago
The comment 0 log now works for me (presuming fixed by bug 1275796).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1275796
You need to log in before you can comment on or make changes to this bug.