Closed Bug 1271804 Opened 3 years ago Closed 3 years ago

Decouple Puppeteer from MarionetteTestCase

Categories

(Testing :: Firefox UI Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1310632

People

(Reporter: davehunt, Unassigned)

References

Details

While it's currently possible to use Firefox Puppeteer as a standalone library, it has been designed as a mixin for a MarionetteTestCase instance. I think it makes sense to decouple Puppeteer, so that it can be instantiated independently. This should mean that we can pass an existing Marionette object on creation of the Puppeteer object, and avoid the get_marionette callback. It will likely mean that tests will need to reference self.puppeteer.windows instead of self.windows, etc.
Moving the tests apart from the firefox-ui/tests folder will be covered by bug 1272145. Using a separate TC task for changes could be implemented later in this bug.
Depends on: 1272145
Blocks: 1272145
No longer depends on: 1272145
No longer blocks: 1272145
Depends on: 1272145
Actually Puppeteer doesn't use MarionetteTestCase. As such I totally missed this bug when filing bug 1310632 as our new tracking bug to get this done. So work will happen over there now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Summary: Decouple Puppeteer from MarionetteTestBase → Decouple Puppeteer from MarionetteTestCase
Duplicate of bug: 1310632
You need to log in before you can comment on or make changes to this bug.