Content is not automatically displayed for "Timeline" and "New Tab" pages when `remember windows and tabs from last time` option is set in `about:preferences`

VERIFIED FIXED

Status

()

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: VladB, Assigned: rrosario)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8751227 [details]
Timeline content.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.0.16

[Affected Platforms]:
- All Windows
- All Mac OS
- All Linux

[Prerequisites]:
- Create a new profile.
- Install Activity Stream through Test Pilot.
- Browse a few links as a new user (50-100 visited websites, 1 bookmarked website).

[Steps to reproduce]:
1. Go to about:preferences->General and select "When Firefox starts: Show my windows and tabs from last time".
2. Click on "Activity Stream" button from browser toolbar.
3. Close all other tabs.
4. Close Firefox.
5. Start Firefox.

[Expected results]:
- Activity Stream Timeline content is automatically displayed with all items in viewport.

[Actual results]:
- For a few seconds the Mozilla start page is displayed and then it is replaced by Activity Stream Timeline. Activity Stream Timeline is empty although there is content in history. Even the Highlight tiles are hidden. Resource link is displayed in the browser address bar.
- If we visit the Bookmarks page from Activity Stream Timeline, we can see that this page is also empty (1 website is bookmarked).
- Content is displayed if the user performs a manual refresh of the page.

[Notes]:
- If we repeat the same scenario for New Tab page, we can observe that the loading spinner is displayed indefinitely with the message "Hang on tight! We are analyzing your history to personalize your experience", until the user refreshes the page.
(Reporter)

Comment 1

2 years ago
Created attachment 8751228 [details]
New Tab content.mp4
This issue was retested on the latest Nightly (49.0a1) build with Activity Stream v1.0.18 but it is reproducible only with e10s disabled.

The issue is reproducible also with this scenarios:
[Prerequisites]:
- Latest Activity Stream add-on version (1.0.18) was previously installed on a old profile.
- Have more history so that the "Highlights" area is populated with visited websites.
- Make sure that e10s is disabled.

[STR]:
1. Click on Activity Stream button from browser toolbar.
2. Press "SHITF + F2" to open the "Developer Toolbar".
3. Write "restart" in the console and press enter.

[Actual results]:
After the browser is restarted, the Mozilla start page is displayed for a few seconds and then it is replaced by Activity Stream Timeline. Activity Stream Timeline is empty although there is content in history. Even the Highlight tiles are hidden.
(Reporter)

Comment 4

2 years ago
via https://github.com/mozilla/activity-stream/pull/896/commits/ff430e6977b4365c00a0dfb756b7ab4d58fe6b0c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
This issue has been verified on Win 8.1 x64, Mac OS X 10.11 and Ubuntu 14.04 x64 with latest Nightly 50.0a1 (Build ID: 20160704030211) using latest Activity Stream v1.1.0-custom build and could not reproduce it.
Thus, marking this issue as Verified-Fixed.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Assignee: nobody → rrosario
You need to log in before you can comment on or make changes to this bug.