Closed Bug 1271950 Opened 8 years ago Closed 8 years ago

The stream example from Fetch API spec text fails with "res.body is undefined"

Categories

(Core :: Networking, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1128959
Tracking Status
firefox49 --- affected

People

(Reporter: jujjyl, Unassigned)

Details

Attachments

(1 file)

STR: Visit https://dl.dropboxusercontent.com/u/40949268/dump/fetch_stream_example.html

(or run the attached file)

This file contains the streamed data download example from https://fetch.spec.whatwg.org/#fetch-api, under the example "If you want to receive the body data progressively:".

Observed:

On Chrome, the data is streamed in progressively and console prints a running sequence of messages "received 11112 bytes (478056 bytes in total)".

On Firefox Nightly, the res.body field seems to be missing and it results in "something went wrong: TypeError: res.body is undefined".
We don't have streams implemented yet.  Working on it bug 1128959 and its dependencies.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: