Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1255336
2 years ago
2 years ago

People

(Reporter: Erik Balchen, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

 After upgrading firefox from 45.0.1 and 45.0.2 to 46.0.1 Silent printing stopped working.


Actual results:

 Both using the print_silent.print toggle in config as well as seamless printing add-on results in blank label pages. Turning off silent print or seamless printing results in perfect labels again.


Expected results:

It should print labels as it does with silent printing turned off. only I dont have to click the OK button.

Comment 1

2 years ago
I don't see the string "print_silent.print" in about:config. Should I create it?

Or could you provide some add-ons offering silent print.
Flags: needinfo?(erik.balchen)
(Reporter)

Comment 2

2 years ago
http://manual.koha-community.org/3.8/en/firefoxreceipt.html
This explains how set up silent printing.. or you can install the add-on called Seamless Print
https://addons.mozilla.org/en-US/firefox/addon/seamless-print/
(Reporter)

Comment 3

2 years ago
(In reply to Loic from comment #1)
> I don't see the string "print_silent.print" in about:config. Should I create
> it?
> 
> Or could you provide some add-ons offering silent print.

 http://manual.koha-community.org/3.8/en/firefoxreceipt.html
This explains how set up silent printing.. or you can install the add-on called Seamless Print
https://addons.mozilla.org/en-US/firefox/addon/seamless-print/

Comment 4

2 years ago
I can't reproduce the issue with my testing profile after installing the add-on Seamless Print.
I saw a similar issue with another add-on, called JS Print Setup (https://addons.mozilla.org/fr/firefox/addon/js-print-setup/).
A bug report has been filed on Github: https://github.com/edabg/jsprintsetup/issues/13

Some people say it works if the user resets his print settings after the update to 46.

Could you make a test with a fresh profile and the add-on Seamless Print installed:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

If it works, there are probably bad print prefs blocking these add-ons to work.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(erik.balchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255336
You need to log in before you can comment on or make changes to this bug.