bookmarks and history sidebar links ignore link prefs

RESOLVED FIXED in Future

Status

SeaMonkey
Sidebar
P3
normal
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: emmet, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020220
BuildID:    2002022003

The bookmarks in the sidebar are now rendered in a new way where they are in the
link colour and underlined like a link. Why? -- the previous version was *much*
easier on the eye.

This bug points out that if the preference is set so that links are not
underlined then the bookmarks should not be either.



Reproducible: Always
Steps to Reproduce:
1.

Comment 1

16 years ago
Confirming on 2002022103 on WinXP.

The history and bookmarks sidebar tabs ignore all the link prefs (underline 
and colours).

Updating summary to reflect.

->Sidebar

Related to bug Bug 114142.
Status: UNCONFIRMED → NEW
Component: Bookmarks → Sidebar
Ever confirmed: true
Summary: bookmarks in sidebar underlined when pref says 'no underline' → bookmarks and history sidebar links ignore link prefs

Comment 2

16 years ago
*** Bug 127229 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Also on Linux 2002022208, platform/os -> all.

This really hurts my eyes :-(
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

16 years ago
*** Bug 126839 has been marked as a duplicate of this bug. ***
I have a patch for this, I think it's in 114142. We're retaining the single
click model but losing the link effect. 
Status: NEW → ASSIGNED
Keywords: nsbeta1
Priority: -- → P3
Target Milestone: --- → mozilla1.0
Actually, this is future. None of our sidebar links will follow this pref for
this release, although the underline will be removed. 
Target Milestone: mozilla1.0 → Future

Comment 7

16 years ago
nsbeta1- per Nav triage team
Keywords: nsbeta1 → nsbeta1-

Comment 8

16 years ago
*** Bug 130573 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Why don't we have the links underline themselves onmouseover?  It's simple, and it
doesn't make the UI look gaudy. With the pointer/hand and a mouseover effect,
any user should figure out that it is a link. 

Comment 10

16 years ago
removing self from cc list
(Reporter)

Comment 11

16 years ago
reversion to original bookmarks rendering in sidebar 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.