"nsRefreshDriver::Tick" spent more time between "domLoading" to "loadEventEnd"

RESOLVED DUPLICATE of bug 1270427

Status

()

Core
General
RESOLVED DUPLICATE of bug 1270427
2 years ago
2 years ago

People

(Reporter: cynthiatang, Unassigned)

Tracking

(Blocks: 1 bug)

45 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Test Case
 1. Launch the browser with blank page
 2. Input the google doc url with 200+ pages content
    https://goo.gl/dK7rR6
 3. Press ctrl+end ( to the last page)
 4. Close the browser

Profiler: https://goo.gl/oB2zPI

Perf Timing domLoading to loadEventEnd: 12443 - 532 = 11911 ms
AddOn Start to End mark: 57055 - 45220 = 11835 ms

From Gecko Profiling data, the Range [45135, 57152]:
 11851  100.0%  Startup::XRE_Main
  4377   36.9%  ├─ Timer::Fire
  3961   33.4%  │  ├─ js::RunScript 
   367    3.1%  │  ├─ nsJSContex::GarbageCollectNow
                │  └─ ...so on
                │
  2446   20.6%  ├─ nsInputStreamPump::OnInputStreamReady
  2210   18.6%  │  ├─ nsInputStreamPump::OnStateStop 
   149    1.3%  │  ├─ nsInputStreamPump::OnStateStart
    44    0.5%  │  └─ nsInputStreamPump::OnStateTransfer
                │
  1641   13.8%  ├─ nsHtml5TreeOpExecutor::RunFlushLoop
  1439   12.1%  │  ├─ nsJSUtils::EvaluateString
   167    1.4%  │  ├─ EventDispatcher::Dispatch
                │  └─ ...so on
                │
  1522   12.8%  ├─ nsRefreshDriver::Tick 
   912    7.7%  │  ├─ PressShell::Paint
   371    3.1%  │  ├─ PressShell::Flush (Flush_Style)
                │  └─ ...so on
                └─ ...so on

Firefox version: 45.0.2
OS version: Ubuntu 14.04 LTS 64-bit
(Reporter)

Updated

2 years ago
Blocks: 1269695
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270427
You need to log in before you can comment on or make changes to this bug.