Closed Bug 1272323 Opened 4 years ago Closed 4 years ago

Corrupted error messages for a few webextensions

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(firefox46 unaffected, firefox47 wontfix)

RESOLVED DUPLICATE of bug 1271777
Tracking Status
firefox46 --- unaffected
firefox47 --- wontfix

People

(Reporter: vasilica.mihasca, Unassigned)

References

Details

(Keywords: regression)

[Affected versions]:
Firefox 49.0a1 (2016-05-12)
Firefox 48.0a2 (2016-05-12)
Firefox 47.0b4 (20160509171155)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 14.04 32-bit
Mac OS X 10.9.5

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create the xpinstall.signatures.dev-root pref in about:config and set it to true.
3.Install the following webextension: https://addons.allizom.org/en-US/firefox/addon/tab-resize-ica-test/


[Expected Results]:
The webextension is successfully installed.

[Actual Results]:
- The webextension could not be installed because it appears to be corrupted.
- The following error is thrown in Browser Console:
462987903853	addons.webextension.<unknown>	ERROR	Loading extension 'null': Reading manifest: Error processing commands.tab-resize-0-undo.suggested_key.mac: Error processing commands.tab-resize-0-undo.suggested_key.mac: String "MacCtrl+Shift+Z" must match /^(MediaNextTrack|MediaPlayPause|MediaPrevTrack|MediaStop)$/       Log.jsm:753


[Regression Range]:
Last good revision: 584870f1cbc5d060a57e147ce249f736956e2b62
First bad revision: b2a3dc4b161fdfac6db78cc5bbfb1f53a383b65a
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=584870f1cbc5d060a57e147ce249f736956e2b62&tochange=b2a3dc4b161fdfac6db78cc5bbfb1f53a383b65a


I suspect that this issue was regressed by Bug 1225715

[Additional notes]:
I’ve also encountered this issue while installing the following webextensions:
- https://addons.allizom.org/en-US/firefox/addon/turnoffthelights/
- https://addons.allizom.org/en-US/firefox/addon/tampermonkeyy/
Flags: qe-verify+
Flags: needinfo?(kmaglione+bmo)
I think this is the same issue as bug 1271777.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1271777
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.