number of unread mails in the inbox is not updated correctly when selecting the inbox after the mail is recieved

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Thomas List, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

In the folderlist I first select a folder other than Inbox (when starting with
the Inbox folder, there is no problem; the Inbox belongs to a movemail mail
account).  Then I press the "Get Msgs" button - mail is recieved and the number
of unread maisl in folder list is updated correctly. Now i choose the Inbox from
the folder list. The mousepointer changes to the hour glass and the content of
the inbox is listed in the message window. The mouse pointer now does not change
back to normal! When I select one of the new messages, the font of this  message
in the message list changes to normal (non-bold), but the number of unread mails
in the folderlist for the Inbox is not reduced. When selecting another folder
the wrong number is still displayed but when reselecting the Inbox everything is
correct again.

Reproducible: Always
Steps to Reproduce:
1.select other folder than inbox
2.send mail to the according account
3.press "Get Msgs"
4.change folder to inbox
5.selecta new message

Actual Results:  mouse pointer is changed to hour glass, number of unread mails
is not updated

Expected Results:  mouse pointer should be the normal pointer, number of unread
mails reduced by 1
(Reporter)

Comment 1

17 years ago
somehow the build-nr did not end up correctly: 2002020415 
Hardware: Sun → PC

Comment 2

17 years ago
Similar to/dupe of bug 104475? Reporter, have you got multiple mail accounts in
Mozilla too?
(Reporter)

Comment 3

17 years ago
No, I would not say that this is similar to bug 104475. I have multiple mail
accounts but I do not use "Get All New Messages", only the "Get Msgs"-Button
that, as far as I know, should only get the messages for the selected account.
The number of unread mails is updated correctly when receiving the mails from
the server/movemail account, it is not updated correctly when reading the new
message.

Comment 4

16 years ago
Reporter, does this bug still exist?  I had similar problems several weeks ago
and the counter works again for me.
(Reporter)

Comment 5

16 years ago
No, I cannot reproduce it any more (Build 2002041711, 1.0rc1)

Comment 6

16 years ago
marking works for me based on comment #5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
verifying as per comment #5
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.