In a Plain-Text Message, the Word "From" at the Beginning of a Line Is Marked as a Comment

RESOLVED INVALID

Status

MailNews Core
Composition
--
major
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Windows 7 Ultimate SP1
Thunderbird 45.0

When I compose a plain-text message, any line beginning with the word "From" (with upper-case F) is marked as a comment.  The line "From the large tree, a bird called." becomes ">From the large tree, a bird called."  

What is worse is that this does not appear in the compose window.  The > symbol is added when the message is sent.  

This bug report replaces bug #1272195.
That is expected behaviour. The mbox format (https://en.wikipedia.org/wiki/Mbox) separates messages with a line that starts with From.

Hence all other words "From" are escaped with >.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

2 years ago
Changing "From" to ">From" within the body of a message merely because it appears at the beginning of a line of text cannot possibly be correct.  This is happening not only when I compose with "From" explicitly at the beginning of a line but also when Thunderbird wraps a line to put "From" at the beginning of a line.  

A major problem is that the user does not see the > symbol inserted while composing.  The symbol is inserted while sending.  

I composed the following in a test message (not including the lines of asterisks):  
*****************************
This is a test.

From the large tree, a bird called.

This is a test.  This is a test.  This is a test.  This is a test. abcd
From the large tree, a bird called.  This is a test.
*****************************
That is what I saw when I selected Send.  


The message was received as: 
*****************************
This is a test.

>From the large tree, a bird called.

This is a test.  This is a test.  This is a test.  This is a test. abcd
>From the large tree, a bird called.  This is a test.
*****************************
Note that I did NOT compose the message with the second ">From" at the  beginning of a line.  Thunderbird put it there when it wrapped the paragraph.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Thunderbird doesn't add those (afaik), and no matter whether it does or not they would also be added by the mail server that accepts the message, as per https://en.wikipedia.org/wiki/Mbox#cite_ref-2 .  Sadly, there's nothing we can do here, and the current behaviour is "correct".  Sorry about that!
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
I can't even reproduce the problem. Do you send the e-mail as plain text or HTML?
In Plain text, the word from gets a space put in front of it, in HTML, the text is so far indented, that there are already spaces in front of the text.

I see > only if I use Preformat. Note that if you copy from Bugzilla, you automatically get Preformat.

Please attach a received message containing the >.
(Reporter)

Comment 5

2 years ago
Created attachment 8751811 [details]
test.eml

I only use plain-text formatting.
Attachment #8751811 - Attachment mime type: message/rfc822 → text/plain
Comment on attachment 8751811 [details]
test.eml

Please check the preference mailnews.send_plaintext_flowed.

When I set that to false, I get the >, otherwise there are spaces inserted and it looks much better.

Comment 7

2 years ago
If your message has an empty line followed by a first line starting with "From" and it is plain text, that "From" has to be escaped to avoid ambiguity with the mbox format. That problem is as old as the definition of that format, sorry to say. How to do that is the choice of the e-mail client, usually ">From"; with format-flowed, you can go with " From" instead as a single leading space will be ignored (I don't recall the reason right now, but if you enter "  something" with format=flowed it will be expanded to "   something" with 3 rather than 2 spaces, then converted back to 2 spaces when displaying).
(Reporter)

Comment 8

2 years ago
In the attached "test.eml" file, note that there is no blank line immediately above the second ">From" line.  

Here is an example from an actual (non-test) message.  Only the ">From" line and the immediately adjacent lines are shown.  Note that the line above the ">From" line is NOT blank.  Also note that the appended message is not a forwarded or reply message.  Instead, it was pasted from viewing the source of another message, in which the affected line was "From", not ">From".  The example follows the line of asterisks.  

*****************************
    The mail server could not deliver mail to david@rossde.com.  The
account does not exist.

------ This is a copy of the message, including all the headers. ------
>From - Wed Apr 13 16:49:26 2016
Return-path: <HenryPhelps@discoverfripp.labcoatsreview.com>

Comment 9

2 years ago
Whatever, I'm not digging through the standard to find out whether or not a blank line is necessary to trigger the requirement. In an mbox environment, "From - Wed Apr 13 16:49:26 2016" alone would indicate that a new message begins here.

Please familiarize yourself with the specs of the mailbox formats.

Comment 10

2 years ago
FWIW, in the INBOX file of a synchronized IMAP account, I don't see any blank line between the messages, they are separated by a single "From" line directly following the previous message. However, in a local folder, there *is * a blank line before each separating "From" line.
You need to log in before you can comment on or make changes to this bug.