Supposed tab restoration failing on build upgrade

RESOLVED DUPLICATE of bug 1353367

Status

()

Firefox for iOS
General
RESOLVED DUPLICATE of bug 1353367
2 years ago
a year ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
There are reports of tab restoration failing on build upgrade whilst Firefox is in the background whilst users are initiating a manual upgrade of App Store versions.

E.g, App Store (-> Firefox 3.0 to version 4.0)

Reports

* https://twitter.com/mmems/status/730684755679821824
* https://twitter.com/mauriciogardini/status/730558947086729216

Reported workaround is restoring tabs from an iTunes backup in "org.mozilla.ios.Firefox/Documents/tabsState.archive"

In the first Twitter conversation the user had ~50 tabs open.

This bug should start an investigation to see wether we can reproduce this issue.
(Reporter)

Comment 1

2 years ago
iPhone 6 (9.3.1)

=> Installed Firefox 3.0, opened 58 tabs (via Popup test)
=> Downloaded the application container, verified tabState.archive was available and that its contents contained entries of 58 tabs with the URLs from the popup test
=> Backgrounded the application by hitting the home-button
=> Opened the App Store, searched for Firefox and hit the upgrade button
=> Upgraded to Firefox 4.0, session restored all 58 tabs + 'What's New' tab

No luck with this simple test.

Can I induce a memory pressure warning on device (perhaps prior to upgrading or during upgrade?) to see if that does anything? Perhaps induce a memory pressure warning on startup post upgrade too?

Comment 2

a year ago
I lost all tabs after manually updating to Firefox 7.0.

Extracting tabsState.archive from a backup requires third-party software. As far as I can tell, the only way to restore that file without jailbreaking is to fully restore the device, which would lose data in other apps.

Desktop Firefox keeps several copies of session state to prevent total loss. Wouldn't it be prudent to do that on iOS?
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353367
You need to log in before you can comment on or make changes to this bug.