Closed Bug 1272469 Opened 3 years ago Closed 3 years ago

font colors from installed theme used inappropriately on the toolbars

Categories

(Thunderbird :: Theme, defect)

45 Branch
x86
Linux
defect
Not set

Tracking

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird49 fixed, thunderbird_esr4546+ fixed)

RESOLVED FIXED
Thunderbird 49.0
Tracking Status
thunderbird46 --- wontfix
thunderbird47 --- fixed
thunderbird48 --- fixed
thunderbird49 --- fixed
thunderbird_esr45 46+ fixed

People

(Reporter: aceman, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(4 files)

I attach a screenshot of my toolbar in TB45 that uses a lightweight theme. In the image I marked the problems.

On the main toolbar, which now is more white than it used to be (I think this is Firefox's fault), the text of the buttons is not very readable.

On the quick filter bar, the background image from the theme is not used, but the text color from theme is. That does not match with the grey default background and the text is not very readable. In this case, when default background is used, also default text color should be used. It is already done correctly on the pushed Tags button in the image.

Can any of these problems be fixed?

This was not a problem in TB38.
The problem is, the LW-theme has set a light text color (in my opinion too light for the theme background). For every text in the main toolbar it's the LW-theme fault. Can you give me the name of the LW-theme so I can test it?

What I see as a TB bug is that the QFB toolbar uses the LW-theme text color.
(In reply to Richard Marti (:Paenglab) from comment #1)
> The problem is, the LW-theme has set a light text color (in my opinion too
> light for the theme background). For every text in the main toolbar it's the
> LW-theme fault. Can you give me the name of the LW-theme so I can test it?

https://addons.mozilla.org/en-Us/thunderbird/addon/dream-swept/
But the theme text was fine before Firefox started to artifically lighten the background on the toolbars. This crept into TB too now. You can see in TB on the main menu bar the image is darked and the text is better on it (well and the menu also has shadow under the strings).

The lightening/whitening on toolbars in Firefox has ruined most themes in my opinion. They do not look good now (and with enough contrast).

> What I see as a TB bug is that the QFB toolbar uses the LW-theme text color.
Yes.
The save QFB problem also appears in the attachment block in message view (the one saying X attachments: <name> <size>"). Text color from theme, background image not.
Attached patch Bug1272469.patchSplinter Review
This patch fixes the text color issues with LW-themes on QFB- and attachments toolbar.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8752576 - Flags: review?(acelists)
Comment on attachment 8752576 [details] [diff] [review]
Bug1272469.patch

Review of attachment 8752576 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me on Linux, thanks!
Attachment #8752576 - Flags: review?(acelists) → review+
https://hg.mozilla.org/comm-central/rev/d69dbb3c065d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
Patch that applies on aurora

[Approval Request Comment]
User impact if declined: unreadable buttons in QFB. anf attachments toolbars with LW-themes enabled
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8752716 - Flags: review+
Attachment #8752716 - Flags: approval-comm-aurora?
Patch that applies on esr45

[Approval Request Comment]
User impact if declined: unreadable buttons in QFB. anf attachments toolbars with LW-themes enabled
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8752718 - Flags: review+
Attachment #8752718 - Flags: approval-comm-esr45?
I'm not asking for beta because I don't know if it's still based on 45 or higher. Depending on on where it bases you can use either patches.
Even though this is really late, it seems low risk so let's push it to get it into our release candidate on the beta channel.
Comment on attachment 8752718 [details] [diff] [review]
Bug1272469-esr45.patch

[Triage Comment]

http://hg.mozilla.org/releases/comm-beta/rev/03e9226caa21
http://hg.mozilla.org/releases/comm-esr45/rev/8ff3cb312f47

Also pushed to beta, which will be for TB 47.
Attachment #8752718 - Flags: approval-comm-esr45?
Attachment #8752718 - Flags: approval-comm-esr45+
Attachment #8752718 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.