Audio from YouTube videos restarts when switching back to video's tab

RESOLVED DUPLICATE of bug 1272422

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1272422
2 years ago
2 years ago

People

(Reporter: Alex Vanderpol, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160511030221

Steps to reproduce:

Play a video on YouTube, switch to a different tab, switch back to YouTube video after a short time on other tabs.


Actual results:

After a couple seconds the audio restarts from the beginning while the video continues playing normally (sometimes with the proper audio still playing as well). Skipping forward/back in the video fixes this temporarily until the next time switching away from then back to the video's tab. (Worth noting, this issue first appeared in the nightly build from May 12th, and is not present in the build from May 11th.)


Expected results:

Audio should remain synced to the video when switching back to the video's tab, it should not restart from the beginning while the video continues playing as normal.

Comment 1

2 years ago
I can reproduce this issue too.
Nightly 49.0a1 (2016-05-12) on Windows 7 (x86)

Comment 2

2 years ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0 ID:20160512030253

Can confirm that I have the same issue!

Comment 3

2 years ago
I'm seeing this issue with webm content as well on https://areweponyyet.com/smile

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0 ID:20160513030539 CSet: 5a2deb5a9b09df9ad2ca3ac1d0c480be250d31e4
 6:49.50 INFO: Last good revision: 13e4cb81d4eb1c4996daf34c68301ca8a8ab0183
 6:49.50 INFO: First bad revision: 2fe467985f04512869ca7daa1a2db286642ce127
 6:49.50 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=13e4cb81d4eb1c4996daf34c68301ca8a8ab0183&tochange=2fe467985f04512869ca7daa1a2db286642ce127

 6:49.89 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1224973
Blocks: 1224973
Component: Untriaged → Audio/Video
Product: Firefox → Core
[Tracking Requested - why for this release]: Significant regression

Possible dupe of 1272627?
Status: UNCONFIRMED → NEW
tracking-firefox49: --- → ?
Ever confirmed: true
Lookingly slightly harder at deps reveals this is a dupe of 1272422
Status: NEW → RESOLVED
Last Resolved: 2 years ago
tracking-firefox49: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1272422
You need to log in before you can comment on or make changes to this bug.