Post Method Failing Intermittently in Firefox V46 Version

RESOLVED DUPLICATE of bug 1269055

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1269055
2 years ago
2 years ago

People

(Reporter: Anand, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

I have an application which is running fine for last 5 years. This has multiple HTTP POST and GET REST API calls will be made. After the recent V46 version the first POST method fails to get a response without any failure code. The same works fine in V45 as well as in chrome and IE.


Actual results:

The same call after giving OK works fine and receives 200 OK Response.


Expected results:

The POST method should have returned 200 OK or other HTTP codes. Instead POST itself is not intiated.

Is there any known bug with Firefox V46 causing this issue.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269055
Hi Anand, here's a suggestion from our developers for a workaround:  Adjust your server side persistent connection timeout to be about 5 seconds longer than the firefox value. Firefox uses 115 seconds for HTTP/1.x and 180 seconds for HTTP/2.  

Hope that helps. If you try it, please let us know the result.
You need to log in before you can comment on or make changes to this bug.