Closed Bug 127278 Opened 19 years ago Closed 19 years ago

Crashed when entering information in forms

Categories

(Core :: DOM: Core & HTML, defect)

PowerPC
Mac System 9.x
defect
Not set
critical

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: erin, Assigned: alexsavulov)

References

()

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020130
BuildID:    Not sure...a build within the last week though

When I am entering information in a form on an SSL site, Mozilla crashes and
random times. It seems to be related to actually typing the first character into
a form field. I get an 'Mozilla has unexpectedly quit' error in the Finder.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to an SSL site
2. type in a form field


Actual Results:  Crash

Expected Results:  Not crash

I will try to find a publicly accessible site to refer to. So far it has hit me
in my online banking and when I did my taxes online. I will find the build
number when I get home.
Reporter: please install MacsBug and get a stdlog for this crash (details on 
http://www.smfr.org/macsbug.html>). Alternatively, try to repro the crash with a 
Mac OS X build, and get a Crash Reporter log.
->PSM
Assignee: mstoltz → ssaux
Component: Security: General → Client Library
Product: Browser → PSM
QA Contact: bsharma → junruh
Version: other → 2.2
OK, I am on build 2002021903.

It just hit me on a non PSM site. I was on http://www.imdb.com and I had just
typed in a search term and hit go and it quit.

I am just going to install Macsbug and try to repro it.
Attached file Macsbug stdlog
Change component as it is not PSM anymore...happens on non-ssl sites

Attached macsbug stdlog
Component: Client Library → Form Submission
Product: PSM → Browser
Version: 2.2 → other
Since it's not crypto related, assign to component owner.
Assignee: ssaux → alexsavulov
QA Contact: junruh → vladimire
Log doesn't show anything of use. My guess is that this is profile-related, maybe 
wallet. Reporter: try making a new profile, and see if you can crash with that.
I had tried that, but I will try again just to be sure when I get home this evening.
Nope, I still get the crash when I type "rock star" into the search window and
hit the "Go" button. Interestingly, when I type "rock start" and then hit enter,
it works fine!

I have removed the profile and all prefs and I am in classic them.

Anything else I can try?
Also interesting is that I can type in this bugzilla form with no problems.
I have no problems... another thing you could try is install in a completely new
directory, as opposed to overwriting the old build.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
I haven't had this problem in a while. I am fine with the WFM resolution.
verifying
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.