Redirect the donation link in aboutDialog to https://donate.mozilla.org/en-US/thunderbird/about/

RESOLVED FIXED in Thunderbird 49.0

Status

Thunderbird
General
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Magnus Melin)

Tracking

unspecified
Thunderbird 49.0

Thunderbird Tracking Flags

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird_esr4546+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Actually when pressing on "Make a donation" it opens https://donate.mozilla.org/about/ This should be redirected now to https://donate.mozilla.org/thunderbird/about/

In aboutDialog.xul the link is https://sendto.mozilla.org/page/contribute/givenow-seq?source=thunderbird_about

I don't know where this bug should be filed best. So I'll cc rkent.

Comment 1

2 years ago
Richard, can you attach a patch. Since Kent is doing uplifts on Monday and the matter is supposedly urgent, maybe he wants to include this.

Also, could you please add a second patch to "Donate" to the help menu, maybe under "What's New". You're the UX guy, so you'll know where.

BTW, on April 22, 2016 I wrote on TB drivers on the issue of redirecting "What's New":
  https://bugzilla.mozilla.org/show_bug.cgi?id=1266795
  BTW, why don't we do a "Donate" menu item in that section as well?
(but that got ignored).
Flags: needinfo?(rkent)

Updated

2 years ago
Severity: normal → critical
(Reporter)

Comment 2

2 years ago
I'm not sure we need a patch. I think this is more a config of a redirect on the web server.

Comment 3

2 years ago
Right, but we'd need one for the "Donate" menu item. But that's a string change. Or maybe not, since we already have "Make a donation".
(Assignee)

Comment 4

2 years ago
Let's just change the URL, I'll take a look. 

Regarding the Help menu, my work in bug 1134760 adds a link, but the patch got stuck since I don't have a mac and the rework causes some problem on mac that would have to be figured out locally :(
Assignee: nobody → mkmelin+mozilla

Comment 5

2 years ago
(In reply to Magnus Melin from comment #4)
> Let's just change the URL, I'll take a look. 
> 
> Regarding the Help menu, my work in bug 1134760 adds a link, but the patch
> got stuck since I don't have a mac and the rework causes some problem on mac
> that would have to be figured out locally :(

Indeed. There's also Appmenu. And there might even be another bug report floating around somewhere - pretty sure I saw something in the past week.

"Get Involved" also needs to change.  We've been using https://wiki.mozilla.org/Thunderbird#Contributing
See Also: → bug 1134760

Comment 6

2 years ago
(In reply to Magnus Melin from comment #4)
> Let's just change the URL, I'll take a look. 
> Regarding the Help menu, my work in bug 1134760 adds a link, ...

OB, but what's wrong with adding a simple menu item for now using the existing strings?
"Make a donation"
(Assignee)

Comment 7

2 years ago
The localized string for that is not likely to work out for all localizations, it may be totally wrong and look the whole menu look weird.
(Assignee)

Comment 8

2 years ago
Created attachment 8752609 [details] [diff] [review]
bug1272972_about_donate-link.patch

Ideally we should not hardcode en-US but leave that out and let the server redirect as appropriate. 

I notice that's not completely working out atm though.

https://donate.mozilla.org/thunderbird/ -> https://donate.mozilla.org/en-US/thunderbird/ (correct)

https://donate.mozilla.org/thunderbird/about/ -> https://donate.mozilla.org/en-US/about/ (wrong: the Mozilla general donation page)
Attachment #8752609 - Flags: review?(rkent)

Updated

2 years ago
tracking-thunderbird_esr45: --- → ?

Comment 9

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #0)
> Actually when pressing on "Make a donation" it opens
> https://donate.mozilla.org/about/ This should be redirected now to
> https://donate.mozilla.org/thunderbird/about/
> 
> In aboutDialog.xul the link is
> https://sendto.mozilla.org/page/contribute/givenow-
> seq?source=thunderbird_about
> 
> I don't know where this bug should be filed best. So I'll cc rkent.

https://donate.mozilla.org/en-US/thunderbird/about/ works as does https://donate.mozilla.org/foobar/thunderbird/about/

https://donate.mozilla.org/thunderbird/about/ puts you on the generic Mozilla donate page, which of course is not what we want.

I assume there must be some way to insert the Thunderbird locale into this location, and it should redirect to en-US if there is no locale defined. Yet it is important that we get a locale properly defined since Germany and Japan are our top countries.

Bugs are filed at https://github.com/mozilla/donate.mozilla.org/issues with the Thunderbird tag.
Flags: needinfo?(rkent)

Comment 10

2 years ago
Comment on attachment 8752609 [details] [diff] [review]
bug1272972_about_donate-link.patch

Review of attachment 8752609 [details] [diff] [review]:
-----------------------------------------------------------------

Really the correct change should pull the LOCALE in somehow, such as is done from all-thunderbird.js in various locations. But this change works, and given that the donate site does not have any current localization, works for now. So let's use it in the short run. But it would be good to file a followup patch to change this to include a locale, so that in the future when we get the donate links localized, they will work correctly.

Updated

2 years ago
Attachment #8752609 - Flags: review?(rkent) → review+

Comment 11

2 years ago
I was wrong about translation. This gives a German translation for example:

https://donate.mozilla.org/de/thunderbird/about/

Also Japanese: https://donate.mozilla.org/ja/thunderbird/about/

It would be great if we could get the translated link in place soon.

Comment 13

2 years ago
Maybe not. Perhaps %LOCALE% only works in all-thunderbird.js. In this case, we just need to define a preference.
(Assignee)

Comment 14

2 years ago
https://hg.mozilla.org/comm-central/rev/ed578f951bb8 -> FIXED

Locale isn't usually hardcoded in these kind of links. You end up at the proper locale through server side redirect - firefox does that too for this case and it works out for Thunderbird too except for the subdir (thunderbird/about/) as I described comment 8.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
(Assignee)

Updated

2 years ago
tracking-thunderbird_esr45: ? → +

Comment 15

2 years ago
Sorry, I never understood the (cryptic) comment #8.

You coded: https://donate.mozilla.org/en-US/thunderbird/about/

So where does this go if A German, Japanese, French or Spanish user clicks this? To that very page, right?

So why not invest the effort to make it respect the locale?
(Assignee)

Comment 17

2 years ago
(In reply to Jorg K (PTO during summer, NI me) from comment #15)
> So why not invest the effort to make it respect the locale?

It will be respected, just the effort is better spent doing a server side redirect as that will of course be needed for links in general also. E.g. in social media you want to give the right language automatically.

Comment 18

2 years ago
Created attachment 8752730 [details] [diff] [review]
Patch to redirect to https://donate.mozilla.org/%LOCALE%/thunderbird/about

While the web works isn't done, I think it's more useful to send people to the localised page.

This would need to be applied on top of Magnus' patch.

Comment 19

2 years ago
Comment on attachment 8752730 [details] [diff] [review]
Patch to redirect to https://donate.mozilla.org/%LOCALE%/thunderbird/about

Sorry about the trailing space.
Attachment #8752730 - Flags: feedback?(rkent)
Attachment #8752730 - Flags: feedback?(mkmelin+mozilla)

Updated

2 years ago
status-thunderbird_esr45: --- → affected

Comment 20

2 years ago
Comment on attachment 8752730 [details] [diff] [review]
Patch to redirect to https://donate.mozilla.org/%LOCALE%/thunderbird/about

I can confirm that this patch works (at least for my en-US locale) when compiled under esr45. And it would be good to get it into TB 45. It would be good to get Magnus's comments though.
Attachment #8752730 - Flags: feedback?(rkent) → feedback+

Updated

2 years ago
Attachment #8752730 - Flags: feedback?(mkmelin+mozilla) → review?(mkmelin+mozilla)

Comment 21

2 years ago
Comment on attachment 8752609 [details] [diff] [review]
bug1272972_about_donate-link.patch

Since the second patch is pushed on top of this one, there is no reason we should wait to uplift this.
Attachment #8752609 - Flags: approval-comm-esr45+
Attachment #8752609 - Flags: approval-comm-beta+
Attachment #8752609 - Flags: approval-comm-aurora+

Comment 22

2 years ago
I'm leaving this open while we resolve the issue of the second patch. But this is very low risk, so I am willing to consider adding the second patch to TB 45.1.2 even if it misses the release candidate 45.2b1

From my perspective, while "Locale isn't usually hardcoded in these kind of links" is true and we are trying to resolve the MoFo bug that causes this, the first patch also hardcodes locale and is not the best solution after the server side issue is fixed. If we have to hardcode, we might as well hardcode the right locale!

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 24

2 years ago
I wonder if it's a good idea to have the donate link as a pref. There may be some greyzone cases where that would be taken advantage of, e.g. in general distributions can change prefs and still be allowed to use the brand name. Firefox also hardcodes it...

Anyway, I looked at the donation page redirect. I found where the problem is but still need to figure out the proper fix.

Comment 25

2 years ago
We already have:

pref("app.releaseNotesURL", ...
pref("toolkit.crashreporter.infoURL", ...
pref("app.support.baseURL", ...
(Assignee)

Comment 27

2 years ago
(In reply to Jorg K (PTO during summer, NI me) from comment #25)
> We already have:
> 
> pref("app.releaseNotesURL", ...
> pref("toolkit.crashreporter.infoURL", ...
> pref("app.support.baseURL", ...

Yes but it makes no money for anyone so it's not comparable. IIRC some of those are in fact changed in say Ubuntu's Thunderbird version.

Comment 28

2 years ago
(In reply to Magnus Melin from comment #24)
> I wonder if it's a good idea to have the donate link as a pref. There may be
> some greyzone cases where that would be taken advantage of, e.g. in general
> distributions can change prefs and still be allowed to use the brand name.
> Firefox also hardcodes it...
> 
> Anyway, I looked at the donation page redirect. I found where the problem is
> but still need to figure out the proper fix.

That's a good point.

Comment 30

2 years ago
The more like redirect starting place, which works now for the similar https://donate.mozilla.org/thunderbird, is:

https://donate.mozilla.org/thunderbird/about

Comment 32

2 years ago
Comment on attachment 8752730 [details] [diff] [review]
Patch to redirect to https://donate.mozilla.org/%LOCALE%/thunderbird/about

Looks like we won't be using this patch in the end so I'm cancelling the review.

It would be nice of someone could answer my question from comment #29 one day.

Re. comment #30:
https://donate.mozilla.org/thunderbird goes to a TB donation page.
https://donate.mozilla.org/thunderbird/about goes to Mozilla donation pare.
Attachment #8752730 - Flags: review?(mkmelin+mozilla)

Comment 33

2 years ago
"It would be nice of someone could answer my question from comment #29 one day."

My comment 30 was supposed to be the answer. That is, the correct root redirect url should be:

https://donate.mozilla.org/thunderbird/about

Updated

2 years ago
status-thunderbird46: --- → wontfix
status-thunderbird47: --- → fixed
status-thunderbird48: --- → fixed
status-thunderbird_esr45: affected → fixed
tracking-thunderbird_esr45: + → 46+
(Assignee)

Updated

2 years ago
Attachment #8752730 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Blocks: 1277948
(Assignee)

Comment 34

2 years ago
Continuing in bug 1277948 for easier tracking.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.