ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr'

VERIFIED DUPLICATE of bug 127315

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 127315
17 years ago
10 years ago

People

(Reporter: timeless, Assigned: David Hyatt)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
cvs build from lunch(eastern time)
(gdb) p mRawPtr
$2 = (nsIDOMNode *) 0x91b7f00
(gdb) call query_result.get()
$3 = (nsDerivedSafe<nsIDOMNode> *) 0x91ab504

#2  0x2831b079 in nsDebug::Assertion (aStr=0x2932d545 "QueryInterface needed", aExpr=0x2932d527 "query_result.get() == mRawPtr",
    aFile=0x2932d500 "../../../dist/include/xpcom/nsCOMPtr.h", aLine=501) at /home/timeless/mozilla/xpcom/glue/nsDebug.cpp:291
#3  0x29284572 in nsCOMPtr<nsIDOMNode>::Assert_NoQueryNeeded (this=0xbfbfb61c) at ../../../dist/include/xpcom/nsCOMPtr.h:501
#4  0x292935e1 in nsCOMPtr<nsIDOMNode>::nsCOMPtr (this=0xbfbfb61c, aRawPtr=0x91b7f00) at ../../../dist/include/xpcom/nsCOMPtr.h:536
#5  0x290d69bf in nsXULElement::IsAncestor (aParentNode=0x91abe84, aChildNode=0x91b7f00)
    at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:4433
#6  0x290cb9ae in nsXULElement::RemoveChildAt (this=0x91ab540, aIndex=0, aNotify=1)
    at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:2402
#7  0x290c6251 in nsXULElement::RemoveChild (this=0x91ab540, aOldChild=0x91abe84, aReturn=0xbfbfbb88)
    at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:1129
#8  0x282f720c in XPTC_InvokeByIndex (that=0x91ab544, methodIndex=17, paramCount=2, params=0xbfbfbb78)
    at /home/timeless/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:153
#9  0x288efba5 in XPCWrappedNative::CallMethod (ccx=@0xbfbfbc30, mode=CALL_METHOD)
    at /home/timeless/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:1998
#10 0x288f8d0e in XPC_WN_CallMethod (cx=0x8ab7200, obj=0x91367e0, argc=1, argv=0x8bb141c, vp=0xbfbfbd64)
    at /home/timeless/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1266
#11 0x2817647a in js_Invoke (cx=0x8ab7200, argc=1, flags=0) at /home/timeless/mozilla/js/src/jsinterp.c:832
#12 0x281856be in js_Interpret (cx=0x8ab7200, result=0xbfbfc740) at /home/timeless/mozilla/js/src/jsinterp.c:2802
#13 0x281764f8 in js_Invoke (cx=0x8ab7200, argc=1, flags=2) at /home/timeless/mozilla/js/src/jsinterp.c:849
#14 0x2817686f in js_InternalInvoke (cx=0x8ab7200, obj=0x9136830, fval=153166296, flags=0, argc=1, argv=0xbfbfcc24, rval=0xbfbfc908)
    at /home/timeless/mozilla/js/src/jsinterp.c:924
#15 0x28145a95 in JS_CallFunctionValue (cx=0x8ab7200, obj=0x9136830, fval=153166296, argc=1, argv=0xbfbfcc24, rval=0xbfbfc908)
    at /home/timeless/mozilla/js/src/jsapi.c:3415
#16 0x297f1590 in nsJSContext::CallEventHandler (this=0x87c1f00, aTarget=0x9136830, aHandler=0x92121d8, argc=1, argv=0xbfbfcc24,
    aBoolResult=0xbfbfca44, aReverseReturnResult=0) at /home/timeless/mozilla/dom/src/base/nsJSEnvironment.cpp:1015
#17 0x2983aaab in nsJSEventListener::HandleEvent (this=0x90b7d60, aEvent=0x92f2008)
    at /home/timeless/mozilla/dom/src/events/nsJSEventListener.cpp:180
#18 0x28f4a361 in nsEventListenerManager::HandleEventSubType (this=0x91abf40, aListenerStruct=0x904d710, aDOMEvent=0x92f2008,
    aCurrentTarget=0x91abf08, aSubType=1, aPhaseFlags=2) at /home/timeless/mozilla/content/events/src/nsEventListenerManager.cpp:1212
#19 0x28f4c3f0 in nsEventListenerManager::HandleEvent (this=0x91abf40, aPresContext=0x8b39800, aEvent=0xbfbff330,
    aDOMEvent=0xbfbfea38, aCurrentTarget=0x91abf08, aFlags=2, aEventStatus=0xbfbfefec)
    at /home/timeless/mozilla/content/events/src/nsEventListenerManager.cpp:1675
#20 0x290d15fc in nsXULElement::HandleDOMEvent (this=0x91abf00, aPresContext=0x8b39800, aEvent=0xbfbff330, aDOMEvent=0xbfbfea38,
    aFlags=2, aEventStatus=0xbfbfefec) at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:3452
#21 0x290d17ed in nsXULElement::HandleDOMEvent (this=0x91b3b80, aPresContext=0x8b39800, aEvent=0xbfbff330, aDOMEvent=0xbfbfea38,
    aFlags=2, aEventStatus=0xbfbfefec) at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:3470
#22 0x290d17ed in nsXULElement::HandleDOMEvent (this=0x91b3c00, aPresContext=0x8b39800, aEvent=0xbfbff330, aDOMEvent=0xbfbfea38,
    aFlags=2, aEventStatus=0xbfbfefec) at /home/timeless/mozilla/content/xul/content/src/nsXULElement.cpp:3470
#23 0x291dd53a in nsGenericElement::HandleDOMEvent (this=0x9168880, aPresContext=0x8b39800, aEvent=0xbfbff330, aDOMEvent=0xbfbfea38,
    aFlags=1, aEventStatus=0xbfbfefec) at /home/timeless/mozilla/content/base/src/nsGenericElement.cpp:1661
#24 0x28fad13f in nsHTMLInputElement::HandleDOMEvent (this=0x9168880, aPresContext=0x8b39800, aEvent=0xbfbff330, aDOMEvent=0x0,
    aFlags=1, aEventStatus=0xbfbfefec) at /home/timeless/mozilla/content/html/content/src/nsHTMLInputElement.cpp:1213
#25 0x29e2984d in PresShell::HandleEventInternal (this=0x8b39c00, aEvent=0xbfbff330, aView=0x906d180, aFlags=1, aStatus=0xbfbfefec)
    at /home/timeless/mozilla/layout/html/base/src/nsPresShell.cpp:6003
#26 0x29e29289 in PresShell::HandleEvent (this=0x8b39c00, aView=0x906d180, aEvent=0xbfbff330, aEventStatus=0xbfbfefec, aForceHandle=0,
    aHandled=@0xbfbfef84) at /home/timeless/mozilla/layout/html/base/src/nsPresShell.cpp:5926
#27 0x2a1dcf2f in nsViewManager::HandleEvent (this=0x8b6f200, aView=0x8f9a800, aEvent=0xbfbff330, aCaptured=0)
    at /home/timeless/mozilla/view/src/nsViewManager.cpp:2041
#28 0x2a1cd255 in nsView::HandleEvent (this=0x8f9a800, aVM=0x8b6f200, aEvent=0xbfbff330, aCaptured=0)
    at /home/timeless/mozilla/view/src/nsView.cpp:305
#29 0x2a1dc561 in nsViewManager::DispatchEvent (this=0x8b6f200, aEvent=0xbfbff330, aStatus=0xbfbff178)
    at /home/timeless/mozilla/view/src/nsViewManager.cpp:1857
#30 0x2a1cc906 in HandleEvent (aEvent=0xbfbff330) at /home/timeless/mozilla/view/src/nsView.cpp:80
#31 0x295bd348 in nsWidget::DispatchEvent (this=0x8ed8000, aEvent=0xbfbff330, aStatus=@0xbfbff268)
    at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1376
#32 0x295bced9 in nsWidget::DispatchWindowEvent (this=0x8ed8000, event=0xbfbff330)
    at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:1264
#33 0x295ba2c9 in nsWidget::OnInput (this=0x8ed8000, aEvent=@0xbfbff330) at /home/timeless/mozilla/widget/src/gtk/nsWidget.cpp:108
#34 0x295e1719 in nsWidget::OnKey (this=0x8ed8000, aEvent=@0xbfbff330) at /home/timeless/mozilla/widget/src/gtk/nsWidget.h:204

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 127315 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
vrfy dupe. silly mouse button
Status: RESOLVED → VERIFIED
(Reporter)

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.