Closed Bug 1273269 Opened 3 years ago Closed 3 years ago

Event dialog: error "gStartTime is null" when creating tasks

Categories

(Calendar :: Dialogs, defect)

Lightning 5.0
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bv1578, Assigned: bv1578)

Details

Attachments

(1 file)

Steps to reproduce:

- create a new task with the event dialog;
- 1) enable only the due date and change the date or time;
  or
  2) enable only the due date and select a recurrence from the Repeat dropdown menu;

--> in the error console appears the error TypeError: gStartTime is null
Attached patch patch - v1Splinter Review
I overlooked the case of tasks with entry date disabled in bug 1165007.

Case 2 in s.t.r. is caused by the fact that gStartTime is used too soon.
Attachment #8753048 - Flags: review?(makemyday)
Comment on attachment 8753048 [details] [diff] [review]
patch - v1

Review of attachment 8753048 [details] [diff] [review]:
-----------------------------------------------------------------

ltgm, r+ - nice typo in the reviewer name within the commit message, btw ;-)
Attachment #8753048 - Flags: review?(makemyday) → review+
> ltgm, r+ - nice typo in the reviewer name within the commit message, btw ;-)

Funny :) Sorry, I beg your pardon. I've corrected before pushing.

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/2bce281bdc19
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.1
Comment on attachment 8753048 [details] [diff] [review]
patch - v1

This bug is also in aurora.
Attachment #8753048 - Flags: approval-calendar-aurora?(philipp)
Attachment #8753048 - Flags: approval-calendar-aurora?(philipp) → approval-calendar-aurora+
Target Milestone: 5.1 → 5.0
You need to log in before you can comment on or make changes to this bug.