[FIX]"save as" does not work for some links

VERIFIED FIXED in mozilla0.9.9

Status

Core Graveyard
File Handling
P1
major
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: Steffen Motzer, Assigned: bz)

Tracking

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020222
BuildID:    20020222

When I visit the URL and try to download any of the exe or zip files by
right-clicking and selecting "Save Link As" nothing seems to happen. My firewall
log shows that when I try to download the file OggDs.exe Mozilla connects to the
remote server, transmits 475 bytes, receives 304 bytes and then closes the
connection without downloading the file. When I left-click the link Mozilla
transmits 484 bytes and asks me whether I want to save or open the file while
Mozilla downloads it.

Using "save as" to download the other links on that page (i.e. the history file
and the faq) is not broken.

I also can't save the list of the bugs that were reported today on the Bugzilla
page (I suspect this might be caused by the same bug). When I type ctrl+s
nothing happens, but when I type ctrl+u Mozilla opens a file download dialog for
buglist.cgi and tells me that I have chosen to download a file of type:
multipart/x-mixed-replace;x-view-type=view-source


Reproducible: Always
Steps to Reproduce:
1. got to http://www.stud.fernuni-hagen.de/q5045045/
2. right click to download the Ogg DirectShow filter
3. nothing happens

Actual Results:  the download does not start

Expected Results:  Mozilla should download the file
The list of bugs is a totally separate issue.  The fact that you can't save the
links on this page is unrelated to that.

Confirming this bug.  We suck.  We don't _always_ get mime infos for types or
extensions...
Assignee: trudelle → bzbarsky
Status: UNCONFIRMED → NEW
Component: XP Apps → File Handling
Ever confirmed: true
Keywords: mozilla0.9.9, nsbeta1
OS: Windows 2000 → All
Hardware: PC → All
Summary: "save as" does not work for some links → "save as" does not work for some links
Keywords: review
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9

Comment 3

17 years ago
Comment on attachment 71019 [details] [diff] [review]
Patch v1.0

r=law

Sorry I missed these the first time I reviewed this code.
Attachment #71019 - Flags: review+
Summary: "save as" does not work for some links → [FIX]"save as" does not work for some links

Comment 4

17 years ago
Comment on attachment 71019 [details] [diff] [review]
Patch v1.0

sr=jag
Attachment #71019 - Flags: superreview+
a=brendan@mozilla.org on behalf of drivers, for 0.9.9.

/be
Keywords: mozilla0.9.9+
checked into trunk for 0.9.9
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
the url has moved and i'm redirected to http://tobias.everwicked.com/ , where i
cannot find a link to download the OggDirectShow filter.

i followed a link to a frame which has the link "Download current version"
pointing to http://tobias.everwicked.com/download.php?OggDS.exe. however, when i
tried to do a "save link as" for that link, the resulting file picker displays
"download.php.html" as the name and "html, web page only" as the only option.

am a looking at the wrong link? is there another link i could try, eg, the
mozilla nightly build links? or, am i encountering another bug?

thanks!
rs vrfy, since i haven't gotten further feedback.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.